How do I know if bench start is ok?

Hi, everybody,

I have a fresh install on my Ubuntu 16.04 and everything runned ok.
I am studying by the tutorial and after creating my library site and apps, I´ve tried to run

bench start

but I dont think it succeeded, for thats my response. The command seems to freezes with this bottom messages.

I´ve read all the topics on discuss.erpnext, stackoverflow and github, but none was useful for this problem.

Any help will be welcome.

Thanks in advance.


From this screen shot it appears to be working fine, * Running on indicates it, are you able to access your URL?

Hi, Pawan,

Unfortunately, it doesnt work… In a few hours, a set of new messages will spawn.
It seems a problem of my VM installed Ubuntu. I´ll try to install in a real machine.

Thanks for now…(I pretend to be a strong user on Frappe, if it goes right)


Based on your trace, bench has started okay. Maybe a you need to access your port from the host machine.

Those are background jobs being executed.

Those are background jobs being executed.

duh… Silly me…

Yes, that was my problem. Access to the port…
I have tried in a real machine and in a VM. The bench is running OK. I can test at a second terminal (Ctrl+alt+F2) and a simple browser, as Elinks.
I suggest you add to your tutorial on installing bench an observation for trying the install on the same machine, using a second terminal, not on a client machine.

  • Start bench

To start using the bench, use the bench start command

bench start

To login to Frappe / ERPNext, open your browser and go to localhost:8000
If you are in a server without browser,
change to a second terminal (Ctrl+Alt+F2), install and run elinks:

sudo apt-get update
sudo apt-get install elinks
elinks localhost:8000