How I broke my desktop dropdown menu

Hi all,

as I was playing with the new Desktop 2.0, I observed the following:

I put a module on the desktop, e.g. selling:


Then, I want to edit the dropdown menu as to get easier access to DocTypes; I remove blanket order:


So far, so good. Now I hit save – and the dropdown is all gone…


… and I cannot get the dropdown menu again to add items …

Has anyone else observed this, can this be resolved? I tried to reset “home_settings” on the affected user, logout/login, nothing seems to help…

1 Like

Short update: this does not reproduce on system language “en”, but does on “de”, “fr”, … (probably all except en)…

Its not “just a language problem”. If you remove a shortcut of a modul from a custom app (not frappe and/or erpnext), the drobdown menu disappears as well! (no matter which language is set) :roll_eyes:

Hey @lasalesi,

This bug has been fixed. You can check it here #8273


Thanks for the reply. While this resolves the language-related disappearence of the drop-down, we still see this also in EN in some cases, however, so far cannot reliably reproduce it…

But we observe that in some cases, when a module was hidden and then activated again, it will not show up… Anyone else who has this?

1 Like

:+1: Same here!

As of V12.1.6 this bug still persists (German Site)
According to github, this bugfix was pushed on August 29th, but 12.1.6 was released on October 2nd, this fix should’ve been included by then, no? Though, I can not find it in the release notes…

Same problem

Installed Apps

ERPNext: v12.x.x-develop () (develop)

ERPNext France: v0.0.1 (master)

Frappe Framework: v12.x.x-develop () (develop)

Same error for me after trying to customize cards

Unfortunately, as far as I know this still persist. Only workaround is to use English.

As you are using French, have you considered Dokos? It is a fork from ERPNext which originates from France, has a strong FR language set and a different desktop. The contributors contribute back to the ERPNext project.