How to add existing, partially depreciated assets?

We are getting started with ERPnext (migrating from a different system) and need to import existing assets.
I went through all documentation, discuss posts etc. I can find on this topic but I can’t get it the import correctly. It seems the Asset module still contains some serious bugs for adding existing assets (or I am not using the system correctly). As this is probably a rather rare task (uploading existing, partially depreciated assets), I guess this has not come to anyone’s attention?!

This is the rough workflow I followed:

  1. Importing the Assets via Data Import with “Calculate Depreciation” = 0 and “Is Existing Asset” = 1, and the respective amount for “Opening Accumulated Depreciation”
  2. Entering the Gross Purchase Amount for past Available-for-use and Purchase Dates.
  3. Selecting “Calculate Depreciation” and “Allow Monthly Depreciation”, adding “Number of Depreciations Booked”
  4. Adding Finance book details (Depreciation method etc.), setting “Expected Value After Useful Life” = 0
  5. Saving the Draft. Then ERPnext computes the depreciation schedule gets automatically. The schedule looks fine. The first bug is, that the “Depreciation Posting Date” is empty again and the “Value After Depreciation” is a wrong number (should be 0 in my understanding).
  6. I add the missing “Depreciation Posting Date” and save the Draft. After saving, the “Expected Value After Useful Life” is changed (in my case to exactly the amount of the “Opening Accumulated Depreciation” ) and thus the depreciation schedule is somehow changed to meet the new “Expected Value After Useful Life”. I can fix the “Expected Value After Useful Life” again and set it to 0. If I save the Draft again it will add another time the “Opening Accumulated Depreciation” to it and so on. I don’t see any way to keep the right depreciation schedule for future depreciations.

Did anyone in the community upload existing, partially depreciated assets before and how did they do it? Does anyone see a mistake in my workflow?
Your help is highly appreciated. I spent several days trying to upload our assets to ERPnext, can’t find a solution and start to wonder whether the Asset module can actually do it properly…

Any advice? We’d love to get started with ERPnext but are stuck at this stage.
(This is using ERPnext 13.9.2)

There is an issue with the new update. Hope it will be solved soon.

Thanks @Saumyaseelan_Pv for the information! That’s really a problem because we wanted to get started with the system latest end of this week. I have been stuck here more than 1.5 weeks.
Is there a way to downgrade the system to a version when it was still working? How long will it approximately take to fix it? Any ideas how to circumvent it and get the assets uploaded (even if it is a “dirty workaround”)?

There is a new update on Frappe Cloud to Frappe v13.9.2 and ERPnext v13.10.2. Do you know whether this will fix it?

If the releases are unstable and introduce more problems than solving others, I am reluctant to adopt new releases and rather wait for a few months until things are stable. It seems to me that it’s not a rare thing that updates actually introduce more bugs. I still have this issue with another problem where due to an update the Company Abbreviation renaming is broken now (though this is minor compared to the Asset issue here at hand): Renaming company abbreviation is broken: How to fix Cost Center names? - #6 by bluesky

If I delete the finance book and manually add it again, I am able to submit the asset with the depreciation schedule. Can you try the same?

Which version are you using?
The problem I get is that the values in the finance book and thus subsequently the depreciation schedule is automatically changed when saving. No idea how to circumvent this…
Did you do it with an opening balance and past dates?

I tested your suggestion. Unfortunately, there is still a bug: the “Depreciation Posting Date” is dropped when saving the Finance Book. So I need to enter the Depreciation Posting Date again, save it and as soon as as save (or submit) the depreciation schedule is messed up again. Even if I can get it the right schedule and Finance book and want to submit the document it will mess up the table after clicking “Submit”. I don’t see any solution to this problem and it’s really messed up.
I discussed this issue offline with @aakvatech. He suggested to manually close the account for that asset at the end for the missing value. The problem is, that ERPnext distributes the depreciation sum over the “Total Number of Depreciations”. If the depreciation sum is wrong because the “Expected Value After Useful Life” is continuously changed to a wrong value, the depreciations for all months is wrong. I don’t see how the Asset module is usable for existing, partially depreciated assets at the moment.

1 Like

Created an issue here: Creating existing, partially depreciated assets with correct depreciation is impossible · Issue #27431 · frappe/erpnext · GitHub

1 Like

Any ideas for a quickfix (even a “dirty workaround”) to add existing, partially depreciated assets?

have you tried to create existing assets manually? If it is failed, can you give me an example of one asset so that I can try the same.

Yes. I tried it several times with varying settings.
Let’s say as example:
Test Asset bought for 4800 one year ago (01-09-2020). It will be depreciated over 48 months. 1100 is already depreciated. 11 full depreciations are already booked.

This how the depr. schedule looks after saving (monthly depreciations are 100 as it should be):


After submitting, you get this, which is plain wrong:


The end value is 1100 (=Opening Accumulated Depreciation) too low.

Not getting desired result for existing assets which are partially depreciated. We are using WDV method of depreciation.

A guitar purchased on 31-03-2016 @ 11,400 and accumulated depreciation is 6341.76 and no. of depreciations booked are 5 - from Mar’17 to Mar’21.

Total 10 depreciations - so 5 depreciations done & 5 more to be calculated.

When we submit the document, it shows asset as fully depreciated and “Value after Depreciation” shown is negative?

Screenshots attached.

Unfortunately, I think the opening accumulated depreciation is broken. I tested it for several days and couldn’t get it running. In the end, I decided to enter the partially depreciated assets deducting the accumulated depreciation from the purchase value. Really not ideal, but the only solution I could find for this problem. Hopefully, it gets fixed in a future release (otherwise it should get removed).

Would you have a import template as an example?
I’m trying to add the existing assets as well and it’s not very clear what columns to use.

did anyone find any solution to this?
i am adding an existing asset with accumulated depreciation as 0 and system itself calculates some value at end of useful life thereby affecting the entire depreciation calculation incorrectly.