How to copy my erpnext application in gitlab/githab?

in the folder / home / bench / frappe-bench / apps
i make commands -
git init
git add --all
git commit -m ‘first’
git status
after that i get the message
that the contents of the erpnext and frappe directories have been modified but not tracked.

Why isn’t directory content being tracked?

How to copy all applications to gitlab?

Hello @11113,

You are doing a minor mistake, instead of /home/<username>/frappe-bench/apps, you are suppose to git init in your own app i.e. /home/<username>/frappe-bench/apps/<custom-app>.

In short, you do not have to git init all apps in app directory. If you have multiple custom app, you’re suppose to initialize git in each custom app individually.

Hope this helps & resolves your issue.

thanks for the answer.
I tried doing this in the directory
/ home / bench / frappe-bench / apps / erpnext
and I get the error
! [remote rejected] version-12 → version-12 (shallow update not allowed)


I deleted the .git folder and everything worked out.

But now I am trying to install the application on another server and an error occurs.
OSError: [Errno 39] Directory not empty

What could be the problem?

Try to delete the app folder and then run bench get-app again. That usually happens if the previous get-app is interrupted midway and the custom app folder is created but not detected by your bench.

1 Like

Now closing this topic since the solution has been found. :slight_smile: