How to disable automated fetching of buying and selling prices during making entries?

Hi Everyone, does anyone know where can i find the setting to disable it? Right now errors end up happening while making entry because ERPNext fetches prices from previous invoices.

Also, since we sell on online platforms, our prices change very frequently. How can I stop this?

Hi @dextervarun,

Your Item price comes from Price List, so when you perform the buy or sell process the item price list rates automatically.

If you want to add the rate manually first remove all item price list rates from Item Price DocType. then please go to the Stock Setting and if enabled the Auto Insert Item Price If Missing then disable it and then reload (Ctrl + Shift + R) and check it.

When you create a Sales Order or Purchase Order then will not come automated item price.

Please try it and check it.

Thank You!

@NCP seems to work. Thanks as always. :slight_smile:

Do you also know how can I disable the automated fetching of income accounts in the sales invoice? I have 2 accounts - “product sales” and “product returns”. But this also gets fetched automatically based on what entry was made previously.

I have these 2 accounts because in the P&L report, there is no way to see credit & debit columns separately, and i want to track both sales and returns.

Hmm :thinking: @dextervarun,

That for, please go to the company and remove the Default Income Account and reload and check it.

Thank You!

Already tried that, but it doesnt work. It somehow assigns income account to the item, and then fetches it automatically.

Is there a way to actually see sales and returns data separately in reports itself? then I can simply have one income account. Right now it basically shows a combined values of “sales minus returns”.

Remove it from Item Master.

Is there no way to see sales and returns separately in P&L reports?

That for, please go to the General Ledger report and choose the account according.

@NCP please check DM