How to force bench to use specific python version on ubuntu?

Trying to work with bench on ubuntu. Actual python version there is 3.10 right now. When I’m attempting to initialize bench with
bench init frappe-bench
It throws error
Package 'frappe' requires a different Python: 3.8.10 not in '>=3.10'

I’ve tried to initialize virtual environments with conda or python3.8 -m venv, activating them, then installing bench inside and repeating init process. But it seems like bench escapes virtual environment if its launched inside one, and keeps using system version of python (which is incompatible with frappe).

So, my question is - how can I force bench to use specific python version on ubuntu?

Hi @hello1,

Please check it.

If you install version 14 then requires Python version 3.10+.

Check the whole post.

Thank You!

yep, seems like reverting my environment back to python3.10 solved the problem. Not sure why it didn’t work initially

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.