How to hide create workspace and edit from dashboard

How can i hide this option for employees

1 Like

It is fixed in the develop branch.

2 Likes

@NCP i tried but nothing chages

it worked on develop branch.

@NCP any other way from app side?

Remove workspace manager role permission for employee users

@Praveenkumar

i did not assign that role to user

user having emplyee role only

Did you run the bench build --force command?

@NCP edit option gone but create workspace still available

i want to hide create workspace also

Please review the code specifically for editing, not for creating workspaces. If you’d like, you can apply the same logic for creating workspaces as well.

when i applied that code then my checkbox got disable from admin side

admin is not able to click and save role permission checkbox


option

If any “Role Profile” is added, all roles will be shown in read-only mode.

If Role Profile:

If not Role Profile:

@NCP got it Thank you for detailed information, if possible can you help me to remove create workspace

Reference is already there, so try it yourself. If there was no reference, you would need help.

@NCP @Praveenkumar Thank you Praveen and Nihantra for you valuable time and advice

i fixed ,its working fine, Thanks a lot once again