How to hide Customize button from Workspace

Hi,

I want to hide the Customize button(at the right side) and also Toggle Side Bar from Menu in Workspace page. Is there a way to do this?


Did you got the solution? Then please share.

Good idea. This might be useful for certain user roles.

1 Like

Hi @Ishwarya , @Minerva and @bluesky,

Need to create build.json as well. So let me write here how it worked:

hooks.py

app_include_css = [
	"/assets/dsr/css/custom.css"
]

custom.css in bench/apps/custom_app/custom_app/public/css

// remove create Workspace button
.custom-actions {
    display: none;
}

build.json in bench/apps/custom_app/custom_app/public

{
    "css/custom.min.css": [
    "public/css/custom.css"
    ]
}

Thanks!

3 Likes

Could something like this be added to user roles? I don’t want certain users/roles to be able to customize their workspace.

Just, Go to the intended ‚ÄúWorkspace Document‚ÄĚ : >> and check option of ‚ÄúDisable User Customization‚ÄĚ .

Unable to mark the check box. it shows Experimental. Any idea about this???

2 Likes

i have same problem

User wise permission how can i do?

In Version 14 removed ‚ÄúDisable User Customization‚ÄĚ field then how to enable this checkbox?

Thanks
Jecintha

I have the same query. Option is there with name ‚ÄúDisable User Customization‚ÄĚ in Workspace. But it is disabled. How to enable it?

Hi @Sandeep_Kakde,

If not enabled developer mode then please enable it using the command.

bench --site sitename set-config developer_mode 1

Please set your site name in the command.
Then use the Administrator account to check the workspace and set your according.

Thank You!

Hi Nihantra,
Our site is deployed on Frappe Cloud. It only consists of Frappe & ERPNext. How can I enable this field directly on Prod without enabling the developer_mode.

Thanks,
Sandeep Kakde

Hmm :thinking:

@Sandeep_Kakde, In Frappe Cloud have some restricted policy, so I don’t think it is possible.

If you want log with administrator account then provide a login with administrator option in frappe cloud dashboard.
Check it, if you want.

Thank You!

I logged in with the administrator account from frappe cloud. But that option is disabled for admin as well.

It’s a Frappe Cloud restriction.

hi, did you get this to work, I am having the same ‚ÄėExperimental‚Äô thing. I want the user to not be able to customize the already created workspace for the role.