How to hide tis

when i import employee the employee id is getting correctly

they ask for id field when in import but when i manually enter there is no field for id

Hi @amal_31845
There is no field for ID. All DocTypes in Frappe have a primary key called name . This is the unique ID by which you will be finding records and manipulating them using the ORM.

but while we importing they ask for id @Safvan_Ph

@amal_31845 If you are uploading new data to this DocType you can uncheck that ID check box.
It will update automatically. no need to add that column.

oaky but here i want to give the id as my wish it is happening while i import
but it is not happening when i manually insert it i cant do it , iam asking that is that possible @Safvan_Ph

If you want to give the ID as your wish. you can customize the name based on the Prompt.
you can achieve this using customize form and after selecting the doctype select Set By User in naming Rule field.

after save and reload you can see an extra field called name. you can input the id in that field. Then that field to be considered as the unique ID

1 Like