How to import all HSN codes into ERPNext

Although there are plenty of posts about HSN codes but I am unable to import all HSN codes into my ERPNext self hosted version.
I had an impression that if INDIA is selected as country GST and HSN codes automatically gets updated but that’s not the case. GST settings I managed to do but I could not import HSN codes in bulk. Prompt resolution would be appreciated.

There are already 14,000+ HSN codes present in the system. They mostly cover almost all the HSN codes. Check “GST HSN Code” list.

Check the following link for more info: GST Features in ERPNext

Hope this helps.

No these HSN Codes are not present in my ERPNext. On HSN Code field only create new HSN Code is showing none of the HSN Codes. MY ERPNext is a SELF HOSTED on oracle virtual machine

You need to import all the HSN code by excel file

To do so, you will have to allow import for HSN codes. Go to the doctype list, open GST HSN Code, and check “Allow Import (via Data Import Tool)” checkbox.

Hope this helps.

1 Like

That is correct. The HSN codes are supposed to load when India is selected as the country on startup. For this, the HSN and SAC codes are preloaded from the JSON files under the regional settings:

In your case, can you share the ERPNext/Frappe versions and method of install for the VM?

Alternatively, you can run the import as suggested in batches to get the codes.

1 Like


Standalone install on virtualbox
I downloaded virtual box and ERPNext ova file and installed and ran on localhost:8080

Thanks but which excel file. From where shall I get the excel file?

That is via data import. But first, you need to allow data import for HSN codes. Check this: How to import all HSN codes into ERPNext - #5 by michelle

Then go to data import, and search for GST HSN Code and download the template. Fill in the details and upload it.

Hope this helps.

There is no pre-loaded HSN list on my instant which is created for the India region and I have even tried reselecting the country, but no luck.
I have tried enabling the import field, but that is asking me to do it in developer mode, whereas I am not a developer and therefore that is not my prefered way.

Can anyone help me understand, what I have done wrong so the HSN list didn’t show up? and is there any normal way (Not the developer way) to fix this?

Installed Apps

ERPNext: v12.18.0 (version-12)

Frappe Framework: v12.15.0 (version-12)