How to install woocommerce app manually

Hello everybody, I did a bench update to ver.11 but I had to uninstall Woocommerce app to overcome some errors.

Did upgrade and now everything works ok but i dont have woocommerce installed. tried to update but no luck. These are my versions:

frappe@erp:~/frappe-bench$ bench version
/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/requests/ RequestsDependencyWarning: urllib3 (1.23) or chardet (3.0.4) doesn’t match a supported version!
erpnext 11.1.33
erpnext_shopify 2.0.26
frappe 11.1.30

I tried with get-app but I dont know which is the correct url to point.
Can someone point me in the right direction please

Thanks in advance

The WooCommerce integration is in-app in version 11. You should find it under Integrations

Hi , thank you for your reply, the menu is there but I had to delete the app in order to update to version 11.

When I click the link the page is missing

the app was deleted deliberately and I need to know how to reinstall it

Thank you if you can help me re-install woocommerce app

Hello, can anyone point me in the right direction?


@Jose_Echeverria, the woocommerce integration is not a separate app, but just a setting in ERPNext…
so, it is not possible to uninstall it as you claim… there is probably something else that is wrong with your system.

look for other error that you are getting… it might help you debug…

Also, just try running “bench --site <site_name> migrate”. This should fix inconsistencies between you data model and actual database.

Thanks for replying, I tried to repair the install using the migrate but it just updated the doctypes for erpnext and frappe (image below) but the woocommerce menu still doesn’t work.

The problem is that I manage to uninstall the Woocommerce app using bench command “remove-app” , now I need to reinstall it

Can you share the exact command(full command) you used to uninstall the ‘Woocommerce app’.

hi again, sorry for my late reply.

the command I used was: bench remove-app woocommerceconnector
probably the source of the problem is that I had installed the old woocommerce connector that I never managed to make it work.
When I was upgrading to version 11, I had to unistall the woocommerce connector individually to achive the upgrade.
The upgrade was finally possible but at the end I finished with an installation without the woocommerce internal app.
So, following the logic I saw on the verbose when doing the upgrade, I need to know the repository of the new woocommerce app to try to run the commands:

$ bench get-app https://[woocommercerepository].git
$ bench install-app [woocommerce_app]

thanks for helping me out

That git repos has been retired - in April 2018 or so, prior to the release of v11, Woocommerce and Shopify were moved to core from external apps erpnext/erpnext/erpnext_integrations/connectors at develop · frappe/erpnext · GitHub

So perhaps install a fresh v11 or v12 to access and run Woocommerce?