How to set Decimal Precision for each currency?

Hello guys,
I need to set decimal precision for each currency. I made changes in each currency number format to set the decimal precision but no changes. What do I need to do to get it working?


Go to System Setting and change the Currency Precision to the decimal place you want

Hi @Fred1, thanks for the reply. I have tried this already if i set in system settings it applies to all the currency format.
But i need for each currency i need to set decimal precision

Go to the Currency List,select the currency you want to set the “Smallest Currency Fraction Value”

I have set the precision to 5 digits in floating point under system settings.

For EUR I defined a cent as the smallest item “0.01000”.

Yet when I enter a purchase invoice in EUR, I get the Total (EUR) amount shown as EUR 2,028.31325. Why is that not rounded to the cent?

Smallest currency fraction value should be 0.01 which translates to 1 cent

That’s exactly what I have set, no?

Yeah. I think it is a bug. I encountered this as well, and was scratching my head for almost a week over this.