How to set home page for website?

Hello. I set home page like blog or home or lms, but I set it and have the error:
“Page Missing or Moved.
The page you are looking for is missing. This could be because it is moved or there is a typo in the link.”
What should I do?

I try to use this instruction Homepage

but I can’t find Home > Website > Portal > Homepage for start

I found homepage, but it is not working for me. I can’t set default page for website anyway.

Have you created a new home page for your website? If yes, what is the route for that page?

Are you able to access that page from the browser using the full route to that page? If you can then just set this route in the home page field of the website settings.

I don’t create a new home page, because it is created by default.
And route for this page
And if you visit these route everything will be good.
After I set this route, like home in home page field and save it.

But when i try visit I have the error

Page Missing or Moved

The page you are looking for is missing. This could be because it is moved or there is a typo in the link.

I think it is bug.

When I logged I have the problem. But When I am not logging it works!

i think it is work fine now

same here, mate

1 Like

@goldenscrew better create a new webpage and set the webpage on the home page. If you need further query how to do it? please ask, I’m willing to reply to you.

Best Regards,

Noman Haider

I did it. But I have the same problem.
It works good without logining, but when I loging I have an error like above.
I think I have settings, that changes home page for user.

The problem is not setting a new page for homepage
I didn’t change anything in website module, and still get the same error above
This happens when people login

1 Like

Okay, I got it. Please check the workspace list and search “Home” workspace available or not. If not please create a new workspace and name it “Home”. If this trick does not work, please let me know.

Best Regards,
Noman Haider
from Bangladesh

I have workspace Home.

knock me on skype. I can check your screen online.

I have the exact same issue. @goldenscrew Were you able to fix it?

@nomanhaider Have you got any clues?

Thank you!

Create a new webpage. Let’s call it index.

Give a basic HTML layout to it.

Go to Website Settings and change the homepage to index.

The default home may refer to Homepage which was accessible via Homepage Settings in earlier versions. This is the default homepage which is created at the time of installation for all erpnext/frappe installations.

How to translate words on Homepage?

i will create home web page but not working in mobile