How to update ERPNEXT fron V8 to V11

How to update erpnext from v8 to v11.Kindly give me the update commands

Well the commands are simple

bench update

and then

bench update --patch

More can be found here : Bench Commands Cheatsheet

But crucial questions you should answer before updating:

  1. Have you made any changes to any doctypes via the Edit Doctype ?

  2. Have you made any changes to any doctypes via the Customize Form route ? Do you have personalized changes that you want to preserve ?

  3. Have you made changes to the default code in ERPNext / Frappe ?

If your answer to 1 is yes, all those will need to be removed. If no, then all is okay.

If your answer to 2 is yes, then all of them will need to preserved via fixtures which are stored in a custom app.

If your answer to 3 is yes, then you may have to see what can be kept in custom app and what you will have to sacrifice.

I highly recommend you go through the entire process on a spare development server with your current code and database and then think about it on the production.

1 Like

Thank you! for all the 3 questions “No” is the answer.

1 Like

Perfect. Still try updating first on a development machine.

Before update take backup of database and files like this:

bench backup --with-files

you can update it v8 to v11.
please post job here

hm, I heard that before, but also read often that changes made by Customize Form are creating entries in the database only and therefore no custom app is needed to preserve such changes


Hello @vrms,
I have updated my ERPNEXT from v8 to v11. But after an update, I a not able to log in.

any error displaying which you might be able to share with us?

No error Migration & All Update are successful.But i cant able to sign in.

why? what is the homepage displaying?

When I give the credentials & click sign in. There is no response.

Have you tried?
Bench build
Bench clear-cache

On the browser press ctrl+f5?

When i run bench build i receive the following error :
throw err;

Error: Cannot find module ‘rollup’
at Function.Module._resolveFilename (module.js:469:15)
at Function.Module._load (module.js:417:25)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at Object. (/home/frappe/frappe-bench/apps/frappe/rollup/build.js:4:16)
at Module._compile (module.js:570:32)
at Object.Module._extensions…js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)

npm ERR! Linux 4.4.0-1038-aws
npm ERR! argv “/usr/bin/node” “/usr/bin/npm” “run” “production”
npm ERR! node v6.11.3
npm ERR! npm v3.10.10
npm ERR! frappe@ production: FRAPPE_ENV=production node rollup/build.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the frappe@ production script ‘FRAPPE_ENV=production node rollup/build.js’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the frappe package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! FRAPPE_ENV=production node rollup/build.js
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs frappe
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls frappe
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! /home/frappe/frappe-bench/apps/frappe/npm-debug.log

1 Like

Thank you…it worked for me & issue cleared.