HR Options Greyed Out

I’m currently logged in as both an admin and as an HR user/manager and most of the options that I would need to access are greyed out.

The only message I’m getting is that I need to create an Employee first, but the message is really vague because I have already created an employee. And I have multiple items in every Employee submenu.

I had to split this up into two because of the one image limit.

For example,

Either I’m missing something or there’s an issue with the application not updating correctly. I already restarted the supervisor, nginx, mysql, redis, and the server thinking it might change. I cleared the browser cache and reopened in an incognito window but the issue persists.

Is there something that I’m missing or is this app not SANE?

I just realized that the option I highlighted says “Attendance”, but when I go to Attendance, the Employee requirement shows up.

Try clearing your browser cache and reboot your server.

Already done, thanks.

Okay then go to your config folder under frappe bench /apps / erpnext / erpnext / config and look for kindly remove the onboard code and description under each doctype. Then restart your server. Dont just restart nginx make a total reboot on server.

Be careful when removing the on board code and description to avoid syntax error.

Thanks! That worked. I’ll need to look through the other configs for similar options, but I’m glad to know that the configs are pretty easy to read.

I’m going to mark this as solved for now, but I don’t know what effect this will have in the future. If the whole system goes kaputt, I’ll be sure to update this post.

Okay good to hear it works the main function of that is just a restriction and guide. Hope your doing well with erpnext. God Bless