I am facing this from last two weeks in installation of ERPnext on Ubuntu 20

Hi everyone,
Can anyone help me to solve this problem?
I am struggling to solve this issue. I have tried it many time with different users.
But still facing the same issue.
Here is my ERROR on terminal.

fatal: [localhost]: FAILED! => {
“changed”: false,
“invocation”: {
“module_args”: {
“allow_unauthenticated”: false,
“autoclean”: false,
“autoremove”: false,
“cache_valid_time”: 0,
“deb”: null,
“default_release”: null,
“dpkg_options”: “force-confdef,force-confold”,
“force”: false,
“force_apt_get”: false,
“install_recommends”: null,
“only_upgrade”: false,
“package”: null,
“policy_rc_d”: null,
“purge”: false,
“state”: “present”,
“update_cache”: true,
“upgrade”: null
“msg”: “Failed to update apt cache: W:Updating from such a repository can’t be done securely, and is therefore disabled by default., W:See apt-secure(8) manpage for repository creation and user configuration details., E:The repository ‘http://ams2.mirrors.digitalocean.com/mariadb/repo/10.4.20/ubuntu focal Release’ does not have a Release file.”

PLAY RECAP *************************************************************************************************************************************************************
localhost : ok=12 changed=4 unreachable=0 failed=1 skipped=13 rescued=0 ignored=0

Traceback (most recent call last):
File “install.py”, line 500, in
File “install.py”, line 281, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “install.py”, line 416, in run_playbook
success = subprocess.check_call(args, cwd=playbooks_folder, stdout=log_stream, stderr=sys.stderr)
File “/usr/lib/python3.8/subprocess.py”, line 364, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-vvvv’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=erp_administrator’]’ returned non-zero exit status 2.

try to install mariadb manually and then run easy install.

1 Like

Same here. Everything was working just fine for a long while until now. Same server settings, same everything. I am unable to install. Tried installing mariadb first, changing sources but no luck. Very frustrating. Any help?

We used this script to install ERPNext when we faced that mariadb issue.

Save to your instance as install.sh, modify it’s parameters, issue
chmod 755 install.sh
and then

It installs as development environment. You can issue
bench setup production