I install erpnext in my server, but when i brows it give login page disorder like screen short below

i have install erpnext in my server but when i brows, login page is disorder. screen short attached here


please help me.

You seem to have a styling layout issue so try these

‘bench build’
‘bench clear-cache’
‘bench clear-website-cache’
clear browser cache

Is this change in effect so it may be part of your problem? Index page before login page


Try different web browser ,
or switch off your plugins.

Hope this help.

@clarkej, i try all you have mention but still not working. this problem is in my server. but before one is in my laptop

@krnkris, i try from different web browser but still same

thank for command on my issue, the problem is file permission. issue solved

What file where and how did you discover that - please share and post whatever error or log result that led you to conclude this thanks!


@clarkej, i run this command :

chmod o+x (opt/username)

For the record what install notes did you use?

I have been trying this command but keep getting this error “chmod: cannot access ‘opt/frappe-user’: No such file or directory”

Is opt/frappe-user your installed directory?


I was following this command
" chmod o+x (opt/username)"

this chmod o+x (ERPNEXT installed path) should be applied on your installed directory

I installed using Easy Install, should I therefore type " chmod o+x frappe-user"

The installation is under Frappe-user

(Is the opt/ mandatory?)

I have applied
chmod o+x (home/frappe)
frappe is user as well dorectory

I do not know what I am possibility doing wrong but I still get the error that directory does not exist.

  1. I input chmod o+x home/frappe and also chmod o+x home/frappe-user.

  2. I also inserted sudo before chmod

  3. I tried all the above as a root user and as frappe user but still returned the same error that directory cannot be found

What are you facing exactly?
Have you found installed directory?
Can you share screenshot?

Eish, I just deleted that installation and attempting to install using either Docker

Now I’m getting the same messiness. Latest develop.

Tried giving it chmod (with -R), same messiness. And yes, I’ve bench build, bench migrate, bench clear-cache and website-cache etc, but…

Should we create an issue on Github?