ID column shown even after hide_name_column: true

Hi, pretty much the title!

I have this in venta_list.js, noventa_list.js and others yet it’s not working.

frappe.listview_settings['Venta'] = { // And other doctype names
    hide_name_column: true

Thanks in advance

Did you try bench clear-cache

Hi @JPaulMora,

Please reload (Ctrl + Shift + R) the page and check it.

Thank You!

1 Like

Did both @JehadAlariqi and @NCP your suggestion but same result. Thanks


As far I know, hide_name_column: true works only when your doctype has a title field rather than your id(name field). Try to set as “title” other field, and you will see your ID as last column.

After that you can use hide column option …
I think there are some “hardcoded” behavior …

Please, if you found other solution … let me know :slight_smile:
Hope this helps.

1 Like

That was it! Thanks!