Import Error - Unable to import using Data Import Tool

Hello Team,

I am trying to import the data through the Data Import Tool. But the process failed and got this error:

“ImportError: cannot import name ‘sha256_hash’ from ‘’ (/home/user/frappe-bench/apps/frappe/frappe/utils/”

Screenshot from 2024-02-27 12-36-06

Please guide me on t.

Thanks in advance

Hi @Foram,

I think the error coming from the column 1, whenever importing the file then doesn’t take ID columns in excel/csv.

Thank You!

I am getting this error in every import.

Can you elaborate on what you said?

Please check the Import File Errors and Warnnigs Section

There are no file errors or warnings showing.

This is the other import that I am trying, everything is good, but the also it’s showing same error In RQ Jobs.

Are you importing the BOM? right?

I have done the data entry as I was getting errors in importing but the record which I have mentioned above in that I am trying to update.

In this I am importing new data, then also same error

Hmm :thinking:,

Okay I will check and update you.

Please update me soon, as I am stuck here.

As I click on the Start Import, the process doesn’t start.

Hi @Foram,

Please check it.

When you import in the data that represents a tree structure, you need to start by importing the Group Node data first. After that, you import the non-group data and connect it to the appropriate parent group in an excel/csv file. Then, you should double-check everything to ensure accuracy.

We tested this process and it functioned correctly.

Thank You!

Yes, I have followed the same process. The parent node is already created then linking it to the child node.

ERPNext: v15.14.7 (version-15)

Frappe Framework: v15.15.0 (version-15)

I have tried it on multiple instances with the same version, and it throws the same error.

When I click on the Start Import, the process doesn’t start and it throws the error in RQ jobs, and after some time it shows the same button Start Import.

Try with the latest version.

That I have already done.

I am facing a similar issue. Cannot import data through the Data Import Tool. I get no errors. Only “Not Started” status.
Steps to reproduce error:

  • Create Data import
  • Document Type: Territory (tried many different ones, but the most basic one is Territory)
  • Select Import Type > Insert new records
  • I downloaded a template and updated the content to the new entries I want to add (I did this just to double check my content. I have all my imports ready from previous instances)
  • Select my CSV file
  • In preview my Columns are mapped correctly
  • Start import

Expected result: Reload page and import was successful, or even failed
Actual result: Nothing happens. Import status remains “Not Started”
Checking the console in dev mode - nothing happens
Just get:

I urgently need to import my data. I have done this process many times on different versions (V13 and 14) and this is a fresh install of version 15.18.1. I notice 2 new updates, but I cannot confirm if this issue gets fixed in these updates.