Importing csv to update products gives me error


I am trying to import a csv to update all my products and I am gettiing a Duplicate name error
I am trying to update the option to make all products sellable since on my first import I only chose the required fields and it did not include that.

Now I am exporting the csv with data from erpnext and just adding the extra column.
Then I get the error, so in regards of formatting I dont think I made something wrong since I just exported the ready made file from the dashboard.

I suppose I have to remove some column in order to update?



Please check the following link to learn how to use data import tool and enter data in the template when overwriting value in the specific field.

1 Like


That is what I am doing
Still I get errors.

I get an error saying that product code is necessary because the products isn’t auto numbering (rough translation cause I am using it in greek language)

I am pasting bellow the full error i get on every single product
If translated the unicode shows greek but just to show the error

{“message”: “\u039f \u03ba\u03c9\u03b4\u03b9\u03ba\u03cc\u03c2 \u03b5\u03af\u03b4\u03bf\u03c5\u03c2 \u03b5\u03af\u03bd\u03b1\u03b9 \u03b1\u03c0\u03b1\u03c1\u03b1\u03af\u03c4\u03b7\u03c4\u03bf\u03c2 \u03b3\u03b9\u03b1\u03c4\u03af \u03c4\u03bf \u03b5\u03af\u03b4\u03bf\u03c2 \u03b4\u03b5\u03bd \u03b1\u03c1\u03b9\u03b8\u03bc\u03b5\u03af\u03c4\u03b1\u03b9 \u03b1\u03c5\u03c4\u03cc\u03bc\u03b1\u03c4\u03b1”, “indicator”: “red”}

Any ideas on how to fix that? Or what am I doing wrong?

Would you mind providing a bit more details?
Which versions of ERPNext / Frappe do you use? What is exact column that you’re adding? Uploading particular problematic .csv file also might help (you can erase sensitive data beforehand).
Also try switching to English interface and post exact error traceback.


Ok so strange thing.
I changed the language from Greek to English to copy the error I was getting.

Did exact same steps.
This time import worked.

Can it be something wrong when importing with another language ?

That type of duplicate error is not likely to be language-specific issue, I believe. Were product IDs/codes specified in your data import file?

Yes they were.

Just to clarify I did the exact same thing for both languages.

That is I went to import/export page > Chose Item > Unchecked all fields > Chose just the option ‘is a sale item’ and exported with Data.

Then I changed the 0 to 1 and thats it.
The exact same for both.

On Greek language there was an error.
On english it worked instantly.

If you can replicate this, then it might be a bug.

I’m gonna give it a try later with Greek language again and let you know.