Importing data does not start

Hey guys! First time user and poster, recently discovered ERPNext and doing my first (inhouse) deployment

I’m currently trying to import initial data to set up my environment, and have tried to import:

  • Sales
  • Items

My columns map correctly, my data shows no errors, but it does not import the data. There’s no errors thrown up in my console or any indication from ERPNext that there are any issues - clicking on the Start Import button doesn’t seem to be take any actions, the button clicks but nothing else happens

Trying to enter the data manually is ok. I’ve tried the import-csv method but that doesn’t work either

Any help appreciated!

Hi, Please re-check the data file. Data Import doesn’t start without any errors means there is some issue with the data itself.

I also faced same problem in the past and found that there were some data was incorrect in the file.

I just tried with a new template downloaded with the mandatory items only + Item Name:

  • Item Code
  • Item Name
  • Item Group
  • Default Unit of Measure

Only 5 lines as a trial import, but even that does nothing - including screenshot below

I have Gourmet Cookies as a Group and Tray as a UoM added previously:

  1. Did you get the template from Data Import.
  2. Try to import then press f5 after 5-10secs. It usually shows the error after refresh.

From stock settings, is item naming based on naming series?

It must have queued, which is not being processed due to issue with worker and / or scheduler.

Try checking “background jobs” in awesome bar.