'install-app erpnext' error

Hi All

Installing erpnext...
Updating DocTypes for erpnext       : [============                            ]Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 174, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/utils/bench_helper.py", line 94, in <module>
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/utils/bench_helper.py", line 18, in main
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 697, in main
    rv = self.invoke(ctx)
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/core.py", line 535, in invoke
    return callback(*args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/env/local/lib/python2.7/site-packages/click/decorators.py", line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/commands/__init__.py", line 24, in _func
    ret = f(frappe._dict(ctx.obj), *args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/commands/site.py", line 160, in install_app
    _install_app(app, verbose=context.verbose)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/installer.py", line 141, in install_app
    sync_for(name, force=True, sync_everything=True, verbose=verbose, reset_permissions=True)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/sync.py", line 45, in sync_for
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/modules/import_file.py", line 58, in import_file_by_path
    ignore_version=ignore_version, reset_permissions=reset_permissions)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/modules/import_file.py", line 129, in import_doc
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 219, in insert
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 790, in run_post_save_methods
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 666, in run_method
    out = Document.hook(fn)(self, *args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 887, in composer
    return composed(self, method, *args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 870, in runner
    add_to_return_value(self, fn(self, *args, **kwargs))
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/model/document.py", line 660, in <lambda>
    fn = lambda self, *args, **kwargs: getattr(self, method)(*args, **kwargs)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/core/doctype/doctype/doctype.py", line 220, in on_update
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/core/doctype/doctype/doctype.py", line 273, in run_module_method
    module = load_doctype_module(self.name, self.module)
  File "/home/amitha/erpnext8-Majan/frappe-bench/apps/frappe/frappe/modules/utils.py", line 184, in load_doctype_module
    raise ImportError('Module import failed for {0} ({1})'.format(doctype, module_name + ' Error: ' + str(e)))
ImportError: Module import failed for SMS Center (erpnext.selling.doctype.sms_center.sms_center Error: No module named sms_settings.sms_settings)

Can anyone help me to resolve this issue and complete setup please?

You need to update erpnext and frappe.
bench update
because “SMS Setting” DocType move erpnext to frappe apps.

1 Like

Thank you @mainul

Shoul I install erpnext app again after ‘bench update’?

Yes, you need install after update.
But if you got error “table already exists” on install time.

then try:

bench reinstall

Thank You @mainul for the prompt reply

Let me try…


I have installed erpnext by bench update and bench reinstall

but when I tried bench start, it shows following error!

09:27:24 system           | socketio.1 started (pid=3453)
09:27:24 system           | redis_cache.1 started (pid=3454)
09:27:24 redis_cache.1    | 3458:C 24 Aug 09:27:24.179 # Fatal error, can't open config file 'config/redis_cache.conf'
09:27:24 system           | redis_cache.1 stopped (rc=1)
09:27:24 system           | redis_socketio.1 started (pid=3446)
09:27:24 redis_socketio.1 | 3450:C 24 Aug 09:27:24.171 # Fatal error, can't open config file 'config/redis_socketio.conf'
09:27:24 system           | redis_socketio.1 stopped (rc=1)
09:27:24 system           | worker_long.1 started (pid=3451)
09:27:24 system           | worker_short.1 started (pid=3465)
09:27:24 system           | web.1 started (pid=3472)
09:27:24 system           | schedule.1 started (pid=3471)
09:27:24 system           | redis_queue.1 started (pid=3473)
09:27:24 redis_queue.1    | 3476:C 24 Aug 09:27:24.226 # Fatal error, can't open config file 'config/redis_queue.conf'
09:27:24 system           | redis_queue.1 stopped (rc=1)
09:27:24 system           | watch.1 started (pid=3464)
09:27:24 system           | worker_default.1 started (pid=3478)
09:27:24 system           | sending SIGTERM to worker_long.1 (pid 3451)
09:27:24 system           | sending SIGTERM to watch.1 (pid 3464)
09:27:24 system           | sending SIGTERM to web.1 (pid 3472)
09:27:24 system           | sending SIGTERM to schedule.1 (pid 3471)
09:27:24 system           | sending SIGTERM to worker_default.1 (pid 3478)
09:27:24 system           | sending SIGTERM to socketio.1 (pid 3453)
09:27:24 system           | sending SIGTERM to worker_short.1 (pid 3465)
09:27:24 system           | web.1 stopped (rc=-15)
09:27:24 system           | schedule.1 stopped (rc=-15)
09:27:24 system           | worker_long.1 stopped (rc=-15)
09:27:24 system           | worker_short.1 stopped (rc=-15)
09:27:24 system           | worker_default.1 stopped (rc=-15)
09:27:24 system           | socketio.1 stopped (rc=-15)
09:27:24 system           | watch.1 stopped (rc=-15)

How can I solve this?


Solved this issue by

bench setup redis