Install Frappe & ERPNext v13 beta from scratch 100% guarantee(22 steps) on ubuntu 20.04

when you logged in via the IP the url shows as “connection not secure” ?
If yes then rerun the certbot command…

Also check when you ping the URL what IP comes back , ensure its the same as ‘A’ record.

not able to work this out. Can you help me with a link where i can get steps to add custom domain and redo the entire process?

Look at the install process and the ssl process + the update process to v13 , I’ve tested this process it works.

Thanks a lot @msalim79 !

Looks like there is some specific issue on AWS instances, I tried on two GCP ones the steps in the video worked like a charm - Hence currently using GCP instance. Would love to understand if there are a some changes for an AWS instance as the one on AWS is free for a year

Glad that you were able to install with some charm :wink:

1 Like

Hi all, with the entire back and forth that happened while i was installing ERPNext as a Novice, i have listed the final steps that worked for me on Google Cloud Instance right upto getting an SSL for the app. Sharing it for greater benefit, hoping it would help others as well.

ERPNext installation guide

Please feel free to comment on observations.

Thanks to @msalim79 @Tech_Hack_IT for their help.


sudo apt install git

Using snapd and certbot, how to renew the certs?
The last time I renew I think I got error. Sorry I’m not having my computer now so can’t elaborate the error.

Hi ,

I installed successfully on Ubuntu 20.04 using just the following steps:

  1. Install Python3.7

  2. Make sure all necessary packages are installed:

apt install python3-minimal build-essential python3-setuptools

  1. Download the Easy Install script:


  1. Run the script specifying the python environment:

python3 --production --version 13 --python python3.7 --verbose

I used the --verbose flag so I could tell what was going on during the installation and easily pin-point any errors

That’s it!

1 Like
sudo certbot renew

Thanks will test …

@Aditya_Bagarka, from a security perspective try to avoid the user frappe. Every installation guide I have seen so far is using frappe as a user… that becomes a bit too common and easy and can be the source of security breach. Don’t give the other side an easy fight :wink:

Please, someone can help me with the issue below, I have v13 installed and can’t execute the schedule, My Email Campaign doesn’t update and the e-mails are not being sent.

Below, is the image of an email campaign I’m at the finish date already, but the status don’t change.

I tried to force schedule with the command below:

bench execute erpnext.crm.doctype.email_campaign.email_campaign.set_email_campaign_status

but nothing is happening.

Error :

Command ‘git --version’ returned non-zero exit status 127
ERROR: there was a problem while creating myfrappe
Do you wan to rollback this change ? [Y/N ]

why … ?

Thank you, after spending a day on trying to install, i got it working by following your steps to the T. :clap:

Getting below error at step no 17

Traceback (most recent call last):
File “/usr/local/bin/virtualenv”, line 7, in
from virtualenv import main
ImportError: cannot import name ‘main’

Getting frappe

$ git clone GitHub - frappe/frappe: Low code web framework for real world applications, in Python and Javascript --branch version-13-beta --depth 1 --origin upstream

Cloning into ‘frappe’…

remote: Enumerating objects: 3050, done.

remote: Counting objects: 100% (3050/3050), done.

remote: Compressing objects: 100% (2871/2871), done.

remote: Total 3050 (delta 403), reused 1088 (delta 109), pack-reused 0

Receiving objects: 100% (3050/3050), 13.11 MiB | 10.22 MiB/s, done.

Resolving deltas: 100% (403/403), done.

Installing frappe

$ myfrappe/env/bin/python -m pip install -q -U -e myfrappe/apps/frappe

[Errno 2] No such file or directory: ‘myfrappe/env/bin/python’: ‘myfrappe/env/bin/python’

ERROR: There was a problem while creating myfrappe

Do you want to rollback these changes? [y/N]: y

Rolling back Bench “myfrappe”

sudo chown -R $USER:$GROUP ~/.npm
sudo chown -R $USER:$GROUP ~/.config


@adals, I must say, that this is the only guide that has worked on me for installing on Ubuntu 20.04.

And I have also learned a lot during the installation phase, i.e. understanding what is being done and installed at each step.

There is only one query I have. After the successful installation we have to manually run the command: bench start
Is there a way where we can make bench auto-start upon OS boot? That’ll be really helpful


I think what you want is to run the following command at the end:

sudo bench setup production [USER]

(where [USER] is the username you use to log into the server at the command line)

That should put everything in place to have everything start up automatically. Just remember to reboot he server after you have run the command to make sure the server automatically startes everything even after a reboot.

Hope this helps.

BKM :nerd_face:


Yes, i’ve already run that command and also rebooted the server, but bench did not start up automatically. I still had to start it up manually