Install new site on Virtualbox Frappe ErpNext4 and point real domain to erpnext server

Hi,

Question 1: I installed ERPNext4 from virtulabox image. Erpnext working well with site name "erpnext.erpnext-vm" that already installed with image. But When I try to install new site with "frappe --install DBNAME SITENAME" command based on "https://frappe.io/apps/frappe-framework/developers/api/sites". I got following error. Can I add new site with this command? If yes How can Solve this error?

(env)ro...@erpnext:/home/erpnext/frappe-bench# frappe --install erpnext2 site2.com
Traceback (most recent call last):
  File "/home/erpnext/frappe-bench/env/bin/frappe", line 9, in <module>
    load_entry_point('frappe==4.0.0', 'console_scripts', 'frappe')()
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 45, in main
    frappe.init(site, sites_path=sites_path)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 109, in init
    setup_module_map()
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 448, in setup_module_map
    for app in get_all_apps(True):
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 391, in get_all_apps
    apps = get_file_items(os.path.join(sites_path, "apps.txt"), raise_not_found=True)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 460, in get_file_items
    content = read_file(path, raise_not_found=raise_not_found)
  File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 476, in read_file
    raise IOError("{} Not Found".format(path))
IOError: ./apps.txt Not Found
(env)ro...@erpnext:/home/erpnext/frappe-bench#

Question 2: How can I point my real domain name ( mycompany.com ) to my erpnext installation server? Where can I define DNS records?

Thanks

Ali



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/d3e95310-7da7-46ce-97c1-0e07d92efe26%40googlegroups.com.

    For more options, visit https://groups.google.com/d/optout.

On Mon, May 26, 2014 at 4:21 PM, aliosman20 at...@gmail.com wrote:

Hi,

Question 1: I installed ERPNext4 from virtulabox image. Erpnext working well
with site name “erpnext.erpnext-vm” that already installed with image. But
When I try to install new site with “frappe --install DBNAME SITENAME”
command based on
Not Found”. I got
following error. Can I add new site with this command? If yes How can Solve
this error?

(env)ro…@erpnext:/home/erpnext/frappe-bench# frappe --install erpnext2
site2.com
Traceback (most recent call last):
File “/home/erpnext/frappe-bench/env/bin/frappe”, line 9, in
load_entry_point(‘frappe==4.0.0’, ‘console_scripts’, ‘frappe’)()
File “/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py”, line 45, in
main
frappe.init(site, sites_path=sites_path)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/init.py”, line
109, in init
setup_module_map()
File “/home/erpnext/frappe-bench/apps/frappe/frappe/init.py”, line
448, in setup_module_map
for app in get_all_apps(True):
File “/home/erpnext/frappe-bench/apps/frappe/frappe/init.py”, line
391, in get_all_apps
apps = get_file_items(os.path.join(sites_path, “apps.txt”),
raise_not_found=True)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/init.py”, line
460, in get_file_items
content = read_file(path, raise_not_found=raise_not_found)
File “/home/erpnext/frappe-bench/apps/frappe/frappe/init.py”, line
476, in read_file
raise IOError(“{} Not Found”.format(path))
IOError: ./apps.txt Not Found
(env)ro…@erpnext:/home/erpnext/frappe-bench#

Run it from sites directory.

Question 2: How can I point my real domain name ( mycompany.com ) to my
erpnext installation server? Where can I define DNS records?

The vm doesn’t have dns and will respond to any host at the port. You
will have to setup nginx with in virtualhosting mode. If you run more
that one sites, the frappe server will distinguish as per the Host
header (hard coded to erpnext-erpnext.vm in the virtual image).

Thanks

Ali


Note:

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much
    information as you can. Please see it from the point of view of the person
    receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send
    only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do
    not send images as attachments. Links are good. Same goes for any file you
    are going to send.

End of Note

You received this message because you are subscribed to the Google Groups
“ERPNext Developer Forum” group.
To unsubscribe from this group and stop receiving emails from it, send an
email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/erpnext-developer-forum/d3e95310-7da7-46ce-97c1-0e07d92efe26%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thanks,

Pratik
erpnext

Hi Pratik,

I installed new site as you suggested. Now I have new site on sites directory with new database name.

I made some modification on frappe.conf (nginx) like port number and site name etc. to reach on 8082 port to new site.

When I reach this new site http://myip:8082, I see login page but when I enter with username and password, the setup wizard does not start and I looged in to desk directly. But there is no all application on desk even I used administrator user.

What am I worng setup new site on erpnext? Or does the new site mean different that I undertand?

Thanks,




Ali Osman Tekkanat


2014-05-26 15:27 GMT+03:00 Pratik Vyas <pd...@gmail.com>:
On Mon, May 26, 2014 at 4:21 PM, aliosman20 <at...@gmail.com> wrote:
> Hi,
>
> Question 1: I installed ERPNext4 from virtulabox image. Erpnext working well
> with site name "erpnext.erpnext-vm" that already installed with image. But
> When I try to install new site with "frappe --install DBNAME SITENAME"
> command based on
> "https://frappe.io/apps/frappe-framework/developers/api/sites". I got
> following error. Can I add new site with this command? If yes How can Solve
> this error?
>
> (env)ro...@erpnext:/home/erpnext/frappe-bench# frappe --install erpnext2
> site2.com
> Traceback (most recent call last):
> File "/home/erpnext/frappe-bench/env/bin/frappe", line 9, in <module>
> load_entry_point('frappe==4.0.0', 'console_scripts', 'frappe')()
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 45, in
> main
> frappe.init(site, sites_path=sites_path)
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line
> 109, in init
> setup_module_map()
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line
> 448, in setup_module_map
> for app in get_all_apps(True):
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line
> 391, in get_all_apps
> apps = get_file_items(os.path.join(sites_path, "apps.txt"),
> raise_not_found=True)
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line
> 460, in get_file_items
> content = read_file(path, raise_not_found=raise_not_found)
> File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line
> 476, in read_file
> raise IOError("{} Not Found".format(path))
> IOError: ./apps.txt Not Found
> (env)ro...@erpnext:/home/erpnext/frappe-bench#
>

Run it from sites directory.

> Question 2: How can I point my real domain name ( mycompany.com ) to my
> erpnext installation server? Where can I define DNS records?
>

The vm doesn't have dns and will respond to any host at the port. You
will have to setup nginx with in virtualhosting mode. If you run more
that one sites, the frappe server will distinguish as per the Host
header (hard coded to erpnext-erpnext.vm in the virtual image).

> Thanks
>
> Ali
>
> --
> Note:
>
> If you are posting an issue,
> 1. We should be able to replicate it at our end. So please give us as much
> information as you can. Please see it from the point of view of the person
> receiving the communication.
> 2. Paste your code at http://pastebin.com or http://gist.github.com and send
> only the URL via email
> 3. For sending images, use http://imgur.com or other similar services. Do
> not send images as attachments. Links are good. Same goes for any file you
> are going to send.
>
> End of Note
> ---
> You received this message because you are subscribed to the Google Groups
> "ERPNext Developer Forum" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to erpnext-developer-forum+un...@googlegroups.com.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/erpnext-developer-forum/d3e95310-7da7-46ce-97c1-0e07d92efe26%40googlegroups.com.

> For more options, visit https://groups.google.com/d/optout.




Thanks,
--
Pratik
erpnext

--
Note:

If you are posting an issue,
1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note
---
You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CAG8U0EnxFKSsnaHcxqKvjKRZyCJPcnomdR8PznCoEBLbDLthXw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CA%2B-d9uRKEOp_4Dp6YVkvihAthycMT%2BrxZThK_Dh-9fziZP2h5A%40mail.gmail.com.

    For more options, visit https://groups.google.com/d/optout.

On Tue, May 27, 2014 at 7:31 PM, Ali Osman TEKKANAT at...@gmail.com wrote:

Hi Pratik,

I installed new site as you suggested. Now I have new site on sites
directory with new database name.

I made some modification on frappe.conf (nginx) like port number and site
name etc. to reach on 8082 port to new site.

When I reach this new site http://myip:8082, I see login page but when I
enter with username and password, the setup wizard does not start and I
looged in to desk directly. But there is no all application on desk even I
used administrator user.

What am I worng setup new site on erpnext? Or does the new site mean
different that I undertand?

Great, you’re almost there!
Install erpnext and shopping cart on your new site.

frappe --install_app erpnext sitename
frappe --install_app shopping_cart sitename

frappe --install installs the frappe framework. Installing erpnext
and shopping cart are additional steps

Thanks,

Pratik
erpnext

Hi Pratik,

Thanks for your help. I have two sites now and working well.

How the upgrade process will go for my sites? Is this enough to use "./scripts/update.sh" command for all sites?

Thanks,

Ali Osman Tekkanat


2014-05-27 17:23 GMT+03:00 Pratik Vyas <pd...@gmail.com>:
On Tue, May 27, 2014 at 7:31 PM, Ali Osman TEKKANAT <at...@gmail.com> wrote:
> Hi Pratik,
>
> I installed new site as you suggested. Now I have new site on sites
> directory with new database name.
>
> I made some modification on frappe.conf (nginx) like port number and site
> name etc. to reach on 8082 port to new site.
>
> When I reach this new site http://myip:8082, I see login page but when I
> enter with username and password, the setup wizard does not start and I
> looged in to desk directly. But there is no all application on desk even I
> used administrator user.
>
> What am I worng setup new site on erpnext? Or does the new site mean
> different that I undertand?
>

Great, you're almost there!
Install erpnext and shopping cart on your new site.

```
frappe --install_app erpnext sitename
frappe --install_app shopping_cart sitename
```

`frappe --install` installs the frappe framework. Installing erpnext
and shopping cart are additional steps

Thanks,
--
Pratik
erpnext

--
Note:

If you are posting an issue,
1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note
---
You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CAG8U0EmiuxMQjDfbg_EgRQpWANJzZ8PaudRkpgTiU2eCwr02Qg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CA%2B-d9uTSGi5P2nw-%2B9_EkYE3AP8g1YW_w3sa%2BpsyXpF69rjdxg%40mail.gmail.com.

    For more options, visit https://groups.google.com/d/optout.

On Fri, May 30, 2014 at 2:28 PM, Ali Osman TEKKANAT at...@gmail.com wrote:

Hi Pratik,

Thanks for your help. I have two sites now and working well.

How the upgrade process will go for my sites? Is this enough to use
“./scripts/update.sh” command for all sites?

It should be, but if you don’t see patches running for all sites, then
you can manually run them using,

frappe --latest sitename

(adjust the path to frappe and run this from the sites directory)

Thanks,

Pratik
erpnext

Hi Pratik,

Before I successfully added new site as you suggestion but I got this error even I used same method now :

(env)root@(none):/home/erpnext/frappe-bench/sites# frappe --install lonsaa lonsaa.com
Traceback (most recent call last):
File "/home/erpnext/frappe-bench/env/bin/frappe", line 9, in <module>
load_entry_point('frappe==4.0.0', 'console_scripts', 'frappe')()
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 49, in main
return run(fn, parsed_args)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 77, in run
out = globals().get(fn)(*args.get(fn), **args)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 63, in new_f n
return fn(*args, **new_kwargs)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 290, in inst all
installed = frappe.get_installed_apps()
File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 401, in get_installed_apps
installed = json.loads(db.get_global("installed_apps") or "[]")
File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/werkzeu g/local.py", line 338, in __getattr__
return getattr(self._get_current_object(), name)
File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/werkzeu g/local.py", line 301, in _get_current_object
raise RuntimeError('no object bound to %s' % self.__name__)
RuntimeError: no object bound to db

What is wrong and how can I solve this problem?

Thanks,


Ali Osman


2014-05-30 12:20 GMT+03:00 Pratik Vyas <pd...@gmail.com>:
On Fri, May 30, 2014 at 2:28 PM, Ali Osman TEKKANAT <at...@gmail.com> wrote:
> Hi Pratik,
>
> Thanks for your help. I have two sites now and working well.
>
> How the upgrade process will go for my sites? Is this enough to use
> "./scripts/update.sh" command for all sites?
>

It should be, but if you don't see patches running for all sites, then
you can manually run them using,

`frappe --latest sitename`

(adjust the path to frappe and run this from the sites directory)

Thanks,
--
Pratik
erpnext

--
Note:

If you are posting an issue,
1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note
---
You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CAG8U0E%3Dtydb-pVpmU8HzYyHEprwgGsYoR7Zjvt4HvF0JF-CDXg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CA%2B-d9uQ%2Biys310t86qDhJzQKUp%3DfNoLDabJKJW%3DqtRmfSUqS3A%40mail.gmail.com.

    For more options, visit https://groups.google.com/d/optout.

This is a small bug that we pushed. Will release a fix soon.

On 3 Jun 2014 03:50, "Ali Osman TEKKANAT" <at...@gmail.com> wrote:
Hi Pratik,

Before I successfully added new site as you suggestion but I got this error even I used same method now :

(env)root@(none):/home/erpnext/frappe-bench/sites# frappe --install lonsaa lonsaa.com
Traceback (most recent call last):
File "/home/erpnext/frappe-bench/env/bin/frappe", line 9, in <module>
load_entry_point('frappe==4.0.0', 'console_scripts', 'frappe')()
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 49, in main
return run(fn, parsed_args)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 77, in run
out = globals().get(fn)(*args.get(fn), **args)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 63, in new_f n
return fn(*args, **new_kwargs)
File "/home/erpnext/frappe-bench/apps/frappe/frappe/cli.py", line 290, in inst all
installed = frappe.get_installed_apps()
File "/home/erpnext/frappe-bench/apps/frappe/frappe/__init__.py", line 401, in get_installed_apps
installed = json.loads(db.get_global("installed_apps") or "[]")
File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/werkzeu g/local.py", line 338, in __getattr__
return getattr(self._get_current_object(), name)
File "/home/erpnext/frappe-bench/env/local/lib/python2.7/site-packages/werkzeu g/local.py", line 301, in _get_current_object
raise RuntimeError('no object bound to %s' % self.__name__)
RuntimeError: no object bound to db

What is wrong and how can I solve this problem?

Thanks,


Ali Osman


2014-05-30 12:20 GMT+03:00 Pratik Vyas <pd...@gmail.com>:
On Fri, May 30, 2014 at 2:28 PM, Ali Osman TEKKANAT <at...@gmail.com> wrote:
> Hi Pratik,
>
> Thanks for your help. I have two sites now and working well.
>
> How the upgrade process will go for my sites? Is this enough to use
> "./scripts/update.sh" command for all sites?
>

It should be, but if you don't see patches running for all sites, then
you can manually run them using,

`frappe --latest sitename`

(adjust the path to frappe and run this from the sites directory)

Thanks,
--
Pratik
erpnext

--
Note:

If you are posting an issue,
1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note
---
You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CAG8U0E%3Dtydb-pVpmU8HzYyHEprwgGsYoR7Zjvt4HvF0JF-CDXg%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.



Note:



If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.



    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CA%2B-d9uQ%2Biys310t86qDhJzQKUp%3DfNoLDabJKJW%3DqtRmfSUqS3A%40mail.gmail.com.

For more options, visit https://groups.google.com/d/optout.

On Tue, Jun 3, 2014 at 10:22 AM, Pratik Vyas pd...@gmail.com wrote:

This is a small bug that we pushed. Will release a fix soon.

Fix merged to develop today.

Hi Pratik,

Thanks for feedback. It is working now.

1-I thing there is someting wrong on setup wizard. If I add logo, picture, vat, item etc. setup wizard give me an error. But if I only add required fields no picture, logo, vat, tiem etc, there is no problem with setup process.

2-And I saw Turkish Chart of Account(Tek Düzen Hesap Planı) on installation new site. How can I enable Turkish Chart of Account for company?

3- How can I prepare language file for Turkish and install the erpnext?

Thanks,

Ali Osman Tekkanat


2014-06-04 9:37 GMT+03:00 Pratik Vyas <pd...@gmail.com>:
On Tue, Jun 3, 2014 at 10:22 AM, Pratik Vyas <pd...@gmail.com> wrote:
> This is a small bug that we pushed. Will release a fix soon.
>

Fix merged to develop today.

--
Note:

If you are posting an issue,
1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

End of Note
---
You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.
To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CAG8U0EnhBRmE2suv%3Dp5fsoZaDwmdVjmRqGk9F_erNSuQR6YypA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.



Note:

 

If you are posting an issue,

  1. We should be able to replicate it at our end. So please give us as much information as you can. Please see it from the point of view of the person receiving the communication.
  2. Paste your code at http://pastebin.com or http://gist.github.com and send only the URL via email
  3. For sending images, use http://imgur.com or other similar services. Do not send images as attachments. Links are good. Same goes for any file you are going to send.

     

    End of Note



    You received this message because you are subscribed to the Google Groups "ERPNext Developer Forum" group.

    To unsubscribe from this group and stop receiving emails from it, send an email to erpnext-developer-forum+un…@googlegroups.com.

    To view this discussion on the web visit https://groups.google.com/d/msgid/erpnext-developer-forum/CA%2B-d9uQV07xKjo09fX9bkj4%2B2s1_vY8WPJhm5uFSNPijUg7ZzQ%40mail.gmail.com.

    For more options, visit https://groups.google.com/d/optout.

On Wed, Jun 4, 2014 at 4:24 PM, Ali Osman TEKKANAT at...@gmail.com wrote:

Hi Pratik,

Thanks for feedback. It is working now.

1-I thing there is someting wrong on setup wizard. If I add logo, picture,
vat, item etc. setup wizard give me an error. But if I only add required
fields no picture, logo, vat, tiem etc, there is no problem with setup
process.

Please check your error console make an issue on github.

2-And I saw Turkish Chart of Account(Tek Düzen Hesap Planı) on installation
new site. How can I enable Turkish Chart of Account for company?

Chart of accounts are still work in progress. We’ll announce once
they’re usable.

3- How can I prepare language file for Turkish and install the erpnext?

Add an issue on github :slight_smile:

Thanks,

Pratik
erpnext