Install on Amazon EC2


Anybody has tried install ERPNext on amazon ec2?
What linux distro that’s most easy yet stable for linux newcomer?


The easy install script should install fine on Cent OS 7 / Ubuntu 14.04

My centos 7 instance on ec2 got this message when running the command : unknown wget command


Look like the wget is not install… Try “apt-get install wget”

apt-get is for a Debian like, in CentOS you will need to run:

yum install -y wget git python && yum -y groupinstall ‘Development Tools’

Note than python is already installed, but is there is a update available it will update python

1 Like

Tks @williamjmorenor I have installed using easy script successfully. But I don’t know how to access the erpnext site.

I opened browser and put its public dns but it’s not available.

Can you give some hints as I’m not familiar with linux


You need to open some porst in the firewall so you can acces the ERPNext

yum install .y firewalld
systemctl start firewalld
systemctl enable firewalld
firewall-cmd --add-port=80tcp
firewall-cmd --add-port=8000/tcp

the just point to your server ip o server-ip:8000


I think you have to configure Amazon’s firewall also (IIRC it’s called security groups).

hi @williamjmorenor when running firewall-cmd --add-port=80tcp…I got this message:
error: unrecognized arguments: --ad-port=80tcp

Here’s the error when opening the webpage:
Gateway timeout
No route to host



@pdvyas I have opened all traffic types, protocol, source for inbound/outbound…

Succeeded run commands…when opened browser…got connection refused

Can you access it from the server itself?

curl localhost

curl: (7) Failed connect to localhost:80; Connection refused

All scripts/commands run successfully. Any idea?

I managed to get it set up, and it involves applying a different security group to the amazon EC2 instance. You need to make sure the ports are open and that all IP addresses are open. Below is an example of completely open:

you write --ad-port=80/tcp correct is --add-port=80/tcp

@wwalford I followed your security group setting but still doesn’t work. Even with all traffic types are opened, the problem still persists.

I think the problem should be in the server as I followed @pdvyas to run ‘curl localhost’ from PuTTY client and I got: curl: (7) Failed connect to localhost:80; Connection refused

The instance is using CentOS 7 (x86_64) with Updates HVM

Please anybody can help?


@Jonathan_Fanny_Lie yes, seems like the server is not running.

Disable SELinux, reboot and try curl localhost again

If that doesn’t work, post the output of

sudo supervisorctl status
tail -n50 /var/log/nginx/error.log

If SELinux is the issue, the following TE should help.

module frappe_selinux 1.0;

require {
    type user_home_dir_t;
    type httpd_t;
    type user_home_t;
    type soundd_port_t;
    class tcp_socket name_connect;
    class lnk_file read;
    class dir { getattr search };
    class file { read open };

#============= httpd_t ==============

#!!!! This avc is allowed in the current policy
allow httpd_t soundd_port_t:tcp_socket name_connect;

#!!!! This avc is allowed in the current policy
allow httpd_t user_home_dir_t:dir search;

#!!!! This avc is allowed in the current policy
allow httpd_t user_home_t:dir { getattr search };

#!!!! This avc can be allowed using the boolean 'httpd_read_user_content'
allow httpd_t user_home_t:file open;

#!!!! This avc is allowed in the current policy
allow httpd_t user_home_t:file read;

#!!!! This avc is allowed in the current policy
allow httpd_t user_home_t:lnk_file read;

Hi @pdvyas,

sudo supervisorctl status:
frappe:frappe-web RUNNING pid 816, uptime 0:07:51
frappe:frappe-worker RUNNING pid 814, uptime 0:07:51
frappe:frappe-workerbeat RUNNING pid 817, uptime 0:07:51

what is the command to disable SELinux and reboot as I’m not linux user?


Disabled selinux, rebooted,…now when access via browser, it showed login page with signup form … When clicked signup, failed didn;t work anything…
Where is ERPNext? WHere to set up it for the first time?