Install on Ubuntu 18.04 failed always

For a week now i’ve been trying to install ERPNext on my ubuntu machine but it always fails, i had to fix tons of bugs and reinstall ubuntu 3 times and it’s still failing.

Every video and every thread here is outdated and/or doesn’t fix my problem.

Here’s the error

@sturdygamer what bugs are you referring to? You should share your logfile and your machine details so that we can understand what the problem might be.

im running ubuntu 18.04 64-bit fresh install
8gb of ddr4 2400mhz ram
gtx 1050ti

extra info:
i installed pip3, curl, wget, git, python all before i ran
i tried the same on 2 installs and 1 vm all got the exact same result

Log: Hit:1 bionic InReleaseHit:2 http://archive -

Use easy install script. Works fine for us on Ubuntu 18

this is what i use, unless you meant letting the script instal the stuff
i ran the script a couple times on 3 different machines 1 of them was a vm (all of them were fresh installs)
it always results in this exact error

i would actually appreciate if anyone could send me a gui ubuntu vm with erpnext installed on it.

seems like you also had MariaDB setup before running this script.

"msg": "unable to connect to database, check login_user and login_password are correct or /home/sturdygamer/.my.cnf has the credentials. Exception message: (1045, \"Access denied for user 'root'@'localhost' (using password: YES)\")"

The above line has come up multiple times in your log. the script works fine on fresh servers without anything installed prior.

ERPNext’s GitHub README has a link for the vbox image.

network manager restart error. you just need to rerun the install script again.

ill try running it fresh with nothing on it pre installed, as for the vm I mean gui ubuntu not the terminal

also i figured its easier to install it in lxc as a container so if someone has a guide you could send it.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.