Install v10 on a local computer?

I would like to know if it is still possible to install v10 on a local machine. If so, kindly point me to a working script.

Check if this helps.

1 Like

I have a v10 bench in my local machine where I also have v11 and v12. The v10 server is starting but it’s giving me an error while creating a new site that says TypeError: a bytes-like object is required, not 'list'. I think it’s related to different python versions I have, but don’t know how to deal with it. Could anyone help?

I received the same error. Here’s how i solved this issue.

1. bench init --frappe-branch v10.x.x --python /usr/bin/python2 <v10-project-name>
2. bench get-app   
3. cd <v10-project-name>/apps/erpnext
4. git fetch upstream v10.x.x:v10.x.x
5. git checkout 10.x.x
6. cd ../..
7. ./env/bin/pip install -q -U -e ./apps/erpnext
8. bench build --app erpnext
9. bench build
10. bench migrate

You might get error like- import error for erpnext on step - 2 but it will be solved after completing steps below.

1 Like