Installation Error found

when i started setting up the ERPNext i countred this error couldn’t go any further

how to fix it

Traceback (most recent call last): File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 55, in application response = frappe.handler.handle() File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 19, in handle execute_cmd(cmd) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 36, in execute_cmd ret =, **frappe.form_dict) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 880, in call return fn(*args, **newargs) File "/home/frappe/frappe-bench/apps/frappe/frappe/desk/page/setup_wizard/", line 154, in load_messages m = get_dict("page", "setup-wizard") File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 117, in get_dict translation_assets[asset_key].update(get_dict_from_hooks(fortype, name)) File "/home/frappe/frappe-bench/apps/frappe/frappe/", line 130, in get_dict_from_hooks translated_dict.update(frappe.get_attr(method)()) File "/home/frappe/frappe-bench/apps/frappe/frappe/geo/", line 38, in get_translated_dict timezone_name = get_timezone_name(get_timezone(tz), locale=locale, width='short') File "/home/frappe/frappe-bench/env/local/lib/python2.7/site-packages/babel/", line 635, in get_timezone_name info = locale.time_zones.get(zone, {}) AttributeError: 'NoneType' object has no attribute 'time_zones'

the same issue any help?

1 Like

same error …posted earlier

Hi there, got an error on bench update

frappe@erpnext:~/frappe-bench$ bench update
Traceback (most recent call last):
  File "/usr/local/bin/bench", line 9, in <module>
    load_entry_point('bench', 'console_scripts', 'bench')()
  File "/home/frappe/bench-repo/bench/", line 40, in cli
  File "/usr/local/lib/python2.7/dist-packages/click/", line 716, in __call__
    return self.main(*args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 696, in main
    rv = self.invoke(ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 1057, in invoke
    Command.invoke(self, ctx)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 889, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/local/lib/python2.7/dist-packages/click/", line 534, in invoke
    return callback(*args, **kwargs)
  File "/home/frappe/bench-repo/bench/commands/", line 20, in bench_command
  File "/home/frappe/bench-repo/bench/", line 13, in set_frappe_version
    FRAPPE_VERSION = get_current_frappe_version(bench_path=bench_path)
  File "/home/frappe/bench-repo/bench/", line 173, in get_current_frappe_version
    return get_major_version(get_current_version('frappe', bench_path=bench_path))
  File "/home/frappe/bench-repo/bench/", line 199, in get_current_version
    return get_version_from_string(, field='version')
  File "/home/frappe/bench-repo/bench/", line 287, in get_version_from_string
AttributeError: 'NoneType' object has no attribute 'group'

Followed suggestion at

But still not working, any hint?


This was fixed long time back. Anyone else reporting it?

@rmehta yeah, i know …followed same steps as suggested earlier …but no luck.

Downloaded last Dev VM imported DB backup and all is back working now, not sure on what happened.