Installation Error on Digital Ocean droplet

I think there are always error on cloud installation. I have browsed through similar errors but no solution was replied.
Fresh droplet 1ghz and 1 gb ram with Ubuntu 14.04 32bit
Installed all pre-requisitions manually. (Tried same on local pc and it works.)

Error here only when i try to install bench init

Will appreciate if anyone can help. I am documenting all the possible errors and its solution.

try this

sudo apt-get install -y python-software-properties libmariadbclient-dev libssl-dev python-pip
sudo pip install --upgrade pip
sudo pip install mysql-python

you seems to be running 32 bit version, some libraries may give you some issue
you may reinstall to 64 bit version of ubuntu, which is most widely tested and works well.

Thanks for the reply.
I have switched to 64bit.
Will try and get back to you.

Thanks alot. Moved to 64Bit and used the above commands. All went very smooth.

Now up and running.

New issue In Digital Ocean VPS

Emain Domain Setup stuck on saving for long time. and in the end timeout and not saved.

Looks like firewall port blocked?

Any advice?

try to check on /desk#List/Error Log and see what caused the timeout
standard port used for SMTP connections is 25, but configuration may vary depending on your email server

There are no error log registered.
I tried error log first only But i couldnt find any so posted here.
IMap is SSL too.
I am using ZOHO.