Installation failed using easy install script (

i am using

to install erpnext but this error keeps popping up. I have tried a number of steps but
sub process usr bin dpkg returned an error code 1
this error and also
fchownat() /run/redis: invalid argument

there are some other prerequisites to be installed prior running the easy setup script then mentioned in the guide you have been following.

I’d try to throw in those as described here and see whether it helps

also setting the locale as mentioned in your error message (I believe something like sudo localectl set-locale en_US.utf8 should do that) would be an obvious point to check

its already set to that i think

i tried to install python-minimal but this came up

have you installed ALL prerequisites as per these instructions for the easy install script

Easy Install

You may have to install Python 2.7 (eg on Ubuntu 16.04+) by running apt-get install python-minimal
You may also have to install build-essential and python-setuptools by running apt-get install build-essential python-setuptools

and still that REDIS-SERVER problem came up, or ONLY python-minimal?

check this… i tried apt-get install build-essential python-setuptools but something is amiss.