Installation issue of erpnext on frappe

Bench version

doppio 0.0.1
erpnext 14.x.x-develop
frappe 15.x.x-develop
india_compliance 16.0.0-dev
payments 0.0.1

Error

You’re attempting to install ERPNext version 15 with Frappe version 16. This is not supported and will result in broken install. Switch to correct branch before installing.

Hello. If you use frappe 15 you have to install the same version of erpnext.

You can’t use:
erpnext 14.x.x-develop
frappe 15.x.x-develop

You have to use the same version of both: erpnext 15 and frappe 15

@jls this error suddenly starting popup, by the last month, I have created multiple sites using this erpnext-14 with frappe-15.

and the current error shows that I am using erpnext -15 with frappe - 16. but I am actually using erpnext - 14 and frappe -15

Well, it’s not good practice.

The major versions must be the same. Why has it worked for you so far? I don’t know, but probably a new update to frappe version 15 is preventing what you want to do.

The 14 develop branch of erpnext doesn’t even exist anymore.

That it shows version 15 and 16 does not mean anything more than a typing error, not really relevant.

bench switch-to-branch version-15 frappe