Installation issues with fresh installation on Digitalocean

I’m trying to install erpnext on digitalocean droplet and this still occurs.

    File "", line 497, in <module>
  File "", line 278, in install_bench
    run_playbook('site.yml', sudo=True, extra_vars=extra_vars)
  File "", line 413, in run_playbook
    success = subprocess.check_call(args, cwd=playbooks_folder, stdout=log_stream, stderr=sys.stderr)
  File "/usr/lib/python3.8/", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command '['ansible-playbook', '-c', 'local', 'site.yml', '-vvvv', '-e', '@/tmp/extra_vars.json', '--become', '--become-user=frappe']' returned non-zero exit status 2.

Some threads mark this as solved, apparently it’s not, over the last year I have never been able to install erpnext just making new droplets from existing install and cleaning uo the data. This old error still persists. Any concrete solution?

Running ubuntu 20 LTS on digitalocean using easyinstall script

Hopefully someone has a solution to this, every method has been tried, nothing works. This is a real problem, the easy install script is how over 95% of people I believe; will install erpnext, not the hard way. Any one having luck with this?

Last I heard, the easy install script was no-longer supported (see this thread).

From the error text you pasted, it’s impossible to diagnose or provide advice.

For better or worse, my impression is the maintainers are encouraging everyone to:

  • Install via Docker.
  • Rent cloud space from an ERPNext service provider.

Manual installation will always be an option. Speaking from personal experience, it works great once you’ve mastered the process. But getting there is a very challenging journey. Many people don’t have the time to commit to such a thing.

Perhaps someday another installer will appear. (I once had plans for building such a thing, but ran out of time/budget.)

Don’t have much expertise but I have installed ERPNext 13 manually following this step by step guide. This guides you to install ERPNext v12 on Ubuntu 20.04 on a digitalocean droplet. But it works perfectly on any server (I guess, mine is not on digital ocean and it worked perfectly). You can use the same steps to install v13. Just replace 12 with 13 when ever cloing/installing Frappe and ERPNext.

Make sure you read everything line-by-line or you will surely get another error.