Installation of ERPNext

I am trying to install ERPNext on my ubuntu. I have followed the manual steps for that provided on GitHub - frappe/bench: CLI to manage Multi-tenant deployments for Frappe apps but when I am trying to Setting Up ERPNext I am getting this error…
Traceback (most recent call last):
File “/usr/local/bin/bench”, line 5, in
from pkg_resources import load_entry_point
File “/usr/local/lib/python2.7/dist-packages/distribute-0.6.28-py2.7.egg/”, line 2819, in
parse_requirements(requires), Environment()
File “/usr/local/lib/python2.7/dist-packages/distribute-0.6.28-py2.7.egg/”, line 592, in resolve
raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (Jinja2 2.6 (/usr/local/lib/python2.7/dist-packages), Requirement.parse(‘jinja2>=2.7,<2.8’))

Can you please give me solution for this…

uninstall jinja2 and then try again installing erpnext

Refer following link for installation

Thank you for your reply. But I have also tried solution given by you. But the error is not solved yet…

@Zalak can you share the full trace?