Installation on Ubuntu 15.10

I have installed frappe-bench and ERPNext on Ubuntu 15.10. This is personal laptop for development and not production server.
here is my experience after fresh install of Ubuntu 15.10 amd64 desktop:

make sure sudo apt-get update; sudo apt-get upgrade

$ sudo apt-get install python-dev python-setuptools build-essential python-mysqldb git ntp vim screen htop mariadb-server mariadb-common libmysqlclient-dev libxslt1.1 libxslt1-dev redis-server libssl-dev libcrypto++-dev postfix nginx supervisor python-pip fontconfig libxrender1 libxext6 xfonts-75dpi xfonts-base nodejs npm libtiff5-dev libjpeg8-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.5-dev tk8.5-dev python-tk

used libtiff5-dev instead of libtiff4-dev and libmysqlclient-dev instead of libmariadbclient-dev

I tried mysql_secure_installation. I tried manually resetting root password. I couldn’t create bench new-site [sitename]
then I followed after which I could create new site bench new-site [sitename]

ubuntuforum post in brief:

# Stop mysql
sudo /etc/init.d/mysql stop 
sudo killall -9 mysqld
# Make sure no mysqld is exist.
# Run mysql with skip grants to be able to login without any password
sudo mysqld_safe --skip-grant-tables &
#Login as root
mysql -u root

[none] > use mysql;
[mysql] > update user set plugin='' where User='root';
[mysql] > flush privileges;
[mysql] > \q or exit

also had to add following lines in /etc/mysql/my.cnf

character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci

default-character-set = utf8mb4

Stop and start mariadb server

sudo /etc/init.d/mysql stop # or (sudo service mysql stop) 
sudo killall -9 mysqld
sudo service mysql start # or sudo /etc/init.d/mysql restart

I can create new-site and install erpnext and other apps on the site.
Everything is working for now.

1 Like

Does the easy install not work?

No, I didn’t try easy way install first. I did manual install. I didn’t add any repo either.

  1. update user set plugin=‘’ where User=‘root’;
  2. by default plugin=‘unix-socket’
  3. I had to reset mariadb root password
  4. update /etc/mysql/my.cnf