Installation_problem @ ubuntu 22.04 ec2-t3a.medium instance

Web-UI not loading properly

installation process as stated in the documention. (Version --develop 14.X.X)
tried following codes after installation:
bench update --reset
bench build --force
bench migrate
bench clear-cache

you can check if you are on version 13, then the following may help
bench update --reset
bench setup requirements

Sorry, not mentioned earlier, its develop branch. But tried this too and all other found on this forum
like “export node_options=–max_old_space_size=8192”
Its installation is really just opposite to its theme.

Hi @Ulter52

This is most likely an issue related to user permissions on the frappe bench directory.

Here’s what you can try:

  1. Login to your frappe user (or su)
  2. Change permissions on the frappe user home directory by running;
    chmod -R o+rx /home/[frappe-user]
  3. Restart bench and nginx services

This should resolve your issue.

I am new in this forum. I have some questions about this forum. These questions shown below:disappointed_relieved::disappointed_relieved::

If anyone has information about this thread. please guide me below. I am very confused about that​:wink::wink:.

@shashank_shirke I am grateful to you and the forum for taking the time to help me, its really worked.
thank you.

Hi @Ulter52 great to know that it worked.
Don’t forget to mark the post as “Solution” so that it will be helpful to others on this forum.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.