Installed Multiple instances of Bench but not starting new bench

I followed the instruction here to install a second bench. I want to setup a different version. Multi Bench Setup · frappe/bench Wiki · GitHub

However, I cannot seem to start the bench with bench restart (I want it in production too)
The default frappe-bench starts as expected.
The comon config file in the new bench has ne new ports.
When I run bench restart, nothing happens.
My sudo supervisorctl status still looks like …

frappe-bench-redis:frappe-bench-redis-cache RUNNING pid 23352, uptime 0:02:38
frappe-bench-redis:frappe-bench-redis-queue RUNNING pid 23351, uptime 0:02:38
frappe-bench-redis:frappe-bench-redis-socketio RUNNING pid 23353, uptime 0:02:38
frappe-bench-web:frappe-bench-frappe-web RUNNING pid 23349, uptime 0:02:38
frappe-bench-web:frappe-bench-node-socketio RUNNING pid 23350, uptime 0:02:38
frappe-bench-workers:frappe-bench-frappe-default-worker-0 RUNNING pid 23345, uptime 0:02:38
frappe-bench-workers:frappe-bench-frappe-long-worker-0 RUNNING pid 23347, uptime 0:02:38
frappe-bench-workers:frappe-bench-frappe-schedule RUNNING pid 23346, uptime 0:02:38
frappe-bench-workers:frappe-bench-frappe-short-worker-0 RUNNING pid 23348, uptime 0:02:38

What could I be missing here?
Looked online but it really should work since the first bench worked. I have rebooted too.


Check the listener ports to make sure it is up (you might have a conflict of ports)

netstat -tnlp | grep -i listen

Thanks trentmu. Will do.
Had to do a total reinstallation because that installation was very sick.
Now, I have a perfect installation to start with.
Will avoid git unless absolutely necessary. lol.