Installing ERPNext on a Ubuntu 14.04 VPS

WOW!!! Thanks a lot!!! It worked!!! I’m really happy, I was trying a lot for several days!!!

But what is the Admin user name & password? I can’t login :frowning:

During installation you would have been asked to put in the Administrator password.

Username : Administrator

In the case you’ve forgotten, you can run bench set-admin-password <password> inside the frappe-bench folder to set a new password.

I’ve logged in successfully. Problem solved finally. Thanks to everyone who helped me a lot to overcome the issues.

1 Like

Hi all trying to install on Ubuntu 14.04 VPS.

These are what I have done:
sudo python --production

And these were the error:
TASK [Set root Password] *******************************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: [“mysqladmin”, “-u”, “root”, “password”, “mysqlpass1”], “delta”: “0:00:00.007214”, “end”: “2016-08-29 02:06:39.614767”, “failed”: true, “rc”: 1, “start”: “2016-08-29 02:06:39.607553”, “stderr”: “\u0007mysqladmin: connect to server at ‘localhost’ failed\nerror: ‘Access denied for user ‘root’@‘localhost’ (using password: NO)’”, “stdout”: “”, “stdout_lines”: [], “warnings”: []}
to retry, use: --limit @production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=21 changed=14 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 342, in
File “”, line 111, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 292, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 540, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘production/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

Any help is very much appreciated. I managed to install it on my local linux machine without problem.


before you installing erpnext, vps have mysql or mariadb?
if you have mysql before installing erpnext, the best way – uninstall mysql or mariadb first.

Hi komsel,
Thanks for your advice, it works now,