Installing Erpnext on Ubuntu 16.04


I am trying to install Erpnext from Script on ubuntu 16.04.

But getting the following error.

TASK [locale : Check current locale] *******************************************
fatal: [localhost]: FAILED! => {“changed”: true, “cmd”: “localectl”, “delta”: “0:00:00.003378”, “end”: “2018-01-01 08:00:39.905630”, “failed”: true, “rc”: 1, “start”: “2018-01-01 08:00:39.902252”, “stderr”: “Failed to create bus connection: No such file or directory”, “stderr_lines”: [“Failed to create bus connection: No such file or directory”], “stdout”: “”, “stdout_lines”: []}
to retry, use: --limit @/tmp/.bench/playbooks/production/install.retry

PLAY RECAP *********************************************************************
localhost : ok=5 changed=0 unreachable=0 failed=1

Traceback (most recent call last):
File “”, line 388, in
File “”, line 114, in install_bench
run_playbook(‘production/install.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 326, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 541, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘production/install.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘–become’, ‘–become-user=frappe’]’ returned non-zero exit status 2

Does Anyone Have Idea, What is wrong here ?

i get the same problem i tried to install it on Scaleway vm which they use non xeon processors.



I checked my cpuinfo which says below.

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 45
model name : Intel(R) Xeon(R) CPU E5-2609 0 @ 2.40GHz
stepping : 7

It seems to be a xeon processor.

can u make it 2 vprocessoers and rechek please

There are total 4 vprocessors in current system.

saerch for ansible-playbook error in the forum u have to do it manually.


Searching it

but not getting proper solution, I posted it here after searching the forum.


I think something is wrong with the easy install script, I have accomplish my task using manual install using below link.

But the easy install script need to be checked.



I am not great at installations of any scripts, But let me voice out one thing.

I was trying to install ERPNext on an OpenVZ, I tried 3 different providers I faced a lot of issues, As soon as I tried KVM’s I tried it with DigitalOcean, Vultr and I followed the same steps they worked like a charm.

I dont know if this will work for you, But just sharing what worked for me.

Below mentioned are the only steps I followed.
Ubuntu 16.04 64bit Minimal Fresh install.
Logged in with Root -

1 - sudo su
2 - sudo apt-get update && sudo apt-get dist-upgrade
3 - sudo apt-get install python-minimal
4 - wget
5 - sudo python --production --user frappe [Setup a password for Admin and user frappe]

Got the link to login, Used the username and password I created in step 5 and I was good to go.

I used this for direct production environment setup.

Again dont mean to waste your time, Just saying what worked for me.

-Vimal Tank

Hi @justvimal

Appreciate your response, I am using this on VPS as and it is on OpenVZ.

I am trying same thing on my internal server with script and post the output.

But I was using the erpnext on this server earlier but when I upgraded it from 9 to 10, it crashed and update went unsuccessful, as I take daily backup so I decided to make fresh installation and restore the data, and at the time of installation it was giving me the above mentioned error.

I am using erpnext from 7 version on this server with the easy install script, so I am wondering now what is wrong with the openvz now and why it is not going ahead with the latest script.

I assume that the script does the same thing which we do manually (Please correct me if I am wrong here), and that is why I am able to install it manually.

I am just sharing my experience.

Any how let me check it on other hyper visors and I will post soon.


one more addition if any errors pop out relating to ‘The repository ‘cdrom://Ubuntu-Server 16.04.4 LTS Xenial Xerus - Release amd64 (20180228) xenial Release’ does not have a Release file.’
do the following;
sudo nano /etc/apt/sources.list
–and comment the following line
deb cdrom:[Ubuntu-Server 16.04 LTS Xenial Xerus - Release amd64 (20160420.3)]/ xenial main restricted