Installing ERPNext on VM

I am not able to access ERPNext through host computer web browser.
Steps which i followed:-

  1. I installed ERPNext on Oracle Virtual Box centOS 6.5, Everything is working fine and installed properly.
  2. then i performed port-forwarding on virtual-box machine to access it from host computer.
  3. i disabled selinux and stopped Iptables to make it working.

I used port forwarding for ssh client as well.
SSH to guest machine is working fine with “ssh localhost -p 2222” and i am able to access guest machine. But when i am not able to access erpnext through web browser on host machine.

I tried to perform “wget localhost” on Guest machine and i am able to get index page.


I downloaded from VM from erpnext website and installed on virtualBox. But i am still not able to access to ERPNext from web using this VM.

Am i missing any point or did i done any mistake ?

VM from has port forwarding pre configured. So, after starting the vm, you can goto http://localhost:8080 from your browser.

Hi Pdvyas
actually i installed erpnext on my vm. I configured port forwarding as mentioned earlier steps which i followed but still not able to access to website.


This seems to be an issues with virtualbox configuration and is out of scope as you’re able to curl from the vm.

Thanks Pdvyas
Can you guide or point me any reference for this issue. It will be a great help.

Hi @3ddeveloper

to use the preconfigured VM should be sufficient.

If you’re using it from the host machine, try to do it with localhost:8080, otherwise scan your lan and check wether the firewall allows to access your host or if the host is bridged or not.

Basically you need to have NAT or Brigded mode for the VM.

My host has x-x-x-52 and the VM including erpnext has x-x-x-41 which I access by using my DNS by typing simply


Thanks Dan
Even i was trying to use it with bridge network, but i am getting this error while trying to use wget.

Resolving erp (erp)…
Connecting to erp (erp)||:80… failed: No route to host.

Can you let me know how i can resolve this issue.


As I just said…the VM needs specific settings.

Are you using the host-machine to access the VM or are you using another client?

I am using only host machine to access VM. In virtual Box i configured
Network Settings => Bridged Network (wlan0)

Do i need to any other setting as well.

hi @3ddeveloper

you need to check 2 things with VMs:

We have bridged, so this would be ok…

then you need to check /etc/network/interfaces if you’re having the correct settings…I would recommend to use static and not DHCP. If you would like to stick to DHCP you need to scan your LAN for the appropriate IP for ERPNext.

If all is set appropriate and it is STILL not working, then you urgently need to assign your firewall.

Thanks Daniel
I found reason of issue and able to resolve, i captured packets and able to backtrack.
/js/erpnext-web.min.js" failed (13: Permission denied) i am getting this error while accessing website from browser.


Think we can close the topic :+1: