Installing ErpNEXT to a local k3s cluster

I have followed the steps mentioned in the following link to install ERPNext application on a local K3s cluster. Everything has went well. The pods are up and running. However, I cannot access the application on my browser. When I type the following command:
kubectl port-forward --namespace kube-system svc/traefik 8080:80
It gives me the following output.
Forwarding from → 8000
Forwarding from [::1]:8080 → 8000
When I type curl localhost:8080 from another terminal, I get 404 Page Not Found error. Also, in the other terminal I get the following output.
Forwarding from → 8000
Forwarding from [::1]:8080 → 8000
Handling connection for 8080

Can anyone help me out here please. I am stuck. @revant_one you must be knowing something. Or if you have any other alternative of installing ERPNext on kubernetes.

have you installed ingress controller and ingress?

Yes. I suppose it’s happening here.

with this command:

kubectl apply --namespace erpnext -f site-ingress.yaml

Ingress controller?

More about Ingress Controllers | Kubernetes

Check Installation Guide - NGINX Ingress Controller

You need to pass host header.

curl -H "Host:" http://localhost:8080/api/method/version

I guess Ingress controller is installed. As when I install it in the kube-system namespace, I get the following error
Error: rendered manifests contain a resource that already exists. Unable to continue with install: ClusterRole “ingress-nginx” in namespace “” exists and cannot be imported into the current release:

this script runs as test, this works on my Linux laptop

Thanks! I’ll look into this and then get back to you brother.

It seems you missed --k3s-arg "--disable=traefik@server:0"

Traefik seems to be installed. It should not be installed if above option is used.

I think this runs fine. When I type “curl mysite.localhost” it gives me a huge HTML output on the terminal. However, I am not able to access it on browser.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.