Installing on Debian Sid and getting persistant install

I just installed on Debian Sid, and would like to note the following observations because it varies from the logic in the easy setup script you have available on Github.

First, the Maria database packages are already in Sid (also Jessie and Stretch) I believe; so, you don’t need to add the Maria-DB repository.

Second, and more importantly, if you add the repository and install libmariadbclient-dev, the install will not work when running frappe-bench. You need the package libmysqlclient-dev (5.6.28-1 and others) from the Debian repository.

I installed into the /opt directory after chowning the subdirectory to my username. I am able to get Erpnext running, and can enter and store data from the website, but I don’t seem to have a persistant installation that comes up at boot.

At some point in the install I got a warning message that said ‘No Crontab for $user’, and I don’t see any entries created in /etc/crontab

I ran these commands from within the frappe-bench directory

bench setup supervisor
sudo ln -s pwd/config/supervisor.conf /etc/supervisor/conf.d/frappe.conf

bench setup nginx
sudo ln -s pwd/config/nginx.conf /etc/nginx/conf.d/frappe.conf

When i ran bench update, it asked me for my password and then reported

[sudo] password for $user:
unix:///var/run/supervisor.sock no such file

I’m confused about how to get a persistent install that comes up at boot with no users logged in. This will eventually be a headless server, so running as a regular user won’t really work for me.

CC @pdvyas

I just rebooted and nginx is up and serving with the bad gateway message. I started the supervisor daemon manually with:
u@debian1:~$ sudo supervisord
/usr/lib/python2.7/dist-packages/supervisor/ UserWarning: Supervisord is running as root and it is searching for its configuration file in default locations (including its current working directory); you probably want to specify a “-c” argument specifying an absolute path to a configuration file for improved security.
'Supervisord is running as root and it is searching ’
Error: Invalid user name erpnext in section ‘program:frappe-web’ (file: ‘/etc/supervisor/conf.d/frappe.conf’)

So, I figured it had some settings hanging around from when I tried to install earlier with the user “erpnext”. That user no longer exists on the system. I will try reinstalling bench in a different directory.

OK, I reinstalled. This time I created the system user ‘erpnext’, and copied over the /frappe-bench/env and /frappe-bench/log from the folder /home/erpnext I installed into (/opt/erpnext6/). I did this because supervisor was looking for these files here for some reason.

Anyway, I’m giving up on this because this is just a test system anyway. If we decide to go further I will use the setup script on a fresh install of Debian Jessie and shouldn’t have this issue. For now i can just login and start bench manually.

@PapaSmERP yeah, could be due to an earlier installation, most the erpnext stuff is pretty straight-forward and works well most of the times.

@PapaSmERP yeah, could be due to an earlier installation, most the erpnext stuff is pretty straight-forward and works well most of the times.