Installing on Ubuntu 18.04


I am inexperienced with Linux so I have tried several fresh installs with no luck following this tutorial:

Each time I get stuck at the same part with no luck on any google searches of my errors. When I run:

sudo systemctl status mariadb

I get:

/usr/bin/mysql_upgrade: the '--basedir' option is always ignored Looking for 'mysql' as: /usr/bin/mysql Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck Version check failed. Got the following error when calling the 'mysql' command ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: FATAL ERROR: Upgrade failed

Also when I run:

sudo mysql -u root -p

I get:

mysql: unknown variable 'pid-file=/var/run/mysqld/'

What am I missing?

Any help would be much appreciated!


Currently where are you on the install? I’ve installed multiple times with no issues… i know that you are installing on Ubuntu 18.04 but what are your systems specifications? Also did you run mysql_secure_installation? To setup the MySQL server?

My system specs are:
Xeon W3530, 4GB RAM, Nvidia NV98

I no longer have the error Upgrade Failed. I already ran mysql_secure_installation and I am about to log into MariaDB using sudo mysql -u root -p

Hi, have you solved this issue?, I also facing this.

I get “Could not find the requested service mysql” when running easy install. I am using WSL Ubuntu 18.04 on Windows 10 Pro OS build :19042.1052. I got WSL2 also installed and enabled. I tried all possible steps trying to do step by step installation but it fails for mysql. Is there any dependency issues that is not detected by easyinstall script. Any help would be greatly appreciated.

<> EXEC /bin/sh -c 'rm -f -r /root/.ansible/tmp/ansible-tmp-1624429678.7791398-2858-226046764140191/ > /dev/null 2>&1 && sleep 0'
fatal: [localhost]: FAILED! => {
    "changed": false,
    "invocation": {
        "module_args": {
            "arguments": null,
            "daemonize": false,
            "enabled": true,
            "name": "mysql",
            "pattern": null,
            "runlevels": null,
            "sleep": 1,
            "state": "started"
    "msg": "Could not find the requested service mysql: "

RUNNING HANDLER [mariadb : restart mysql] ******************************************************************************************************************************
task path: /tmp/.bench/bench/playbooks/roles/mariadb/handlers/main.yml:2