Insufficient permission for Domain

When creating new company. i cannot put anything in domain box.
also when editing previous company domain. it give me the same error.
i created previous company with same id. and now i cannot change the domain.

1 Like

As per the default permission, only administrator has permission on Domains master. In the Role Permission Manager, create new permission rule for one of the Role which is assigned to the user like System Manager etc.

Hi, I am having just the same problem… only ony company, logged as Administrator. I tried to create a new company and as soon as I click on services, this “Insufficient permission for Domain” appears.

Also if I click on services in the the first company created…

The role Permision Manager, shows the same checkboxes as Umair post.

What have I changed wrong? :roll_eyes:


Found something more… maybe someone can explain better what has happend.

I have two installations, one for test, one production. Seems the test one is where missed perms is.

Production (the OK one):

Here if I go administrator/domain… it is found domain…


Test (the missed permission one):
Here if I go administrator/… cant find domain entry…

I remember trying to create a new role like “Administrator Role” just for testing, and then I delete that role, thats the only thing I remember doing for testing.

How do I add again the permission so Administrator can access “domains”?

(I tried bench reset-perms from command line but I think its not for solving this… dont try it just in case)


1 Like