Insufficient Permission for GST HSN Code

getting this error on new item creation

User is Admin with all roles and modules accessible.

Go to setup, Role Permissions Manager. Select GST HSN Code as the DocType and ensure that the resulting screen permits you the operations that you wish to carry out.

Hope this helps.



1 Like

Hi @JayRam,
It is the admin account with all roles and modules accessible.

I am attaching below the image observed in the role permissions manager

In the System Settings, have you clicked either of the options:

Ignore User Permissions if missing, or
Apply Strict User Permissions

And your User Account shows that the System Manager account has Account Manager Role checked?



Hi @JayRam,

No user permissions have been applied, and all roles and modules are checked.
It is the admin account.


I have the same permissions and it is working on my system, hence I am fishing. Did you do any customization on the GST HSN DocType?



Got solved, no idea how!
Just restarted the complete VM and voila.!

Mysterious are the ways of technology.

I had the same issue. A restart did the trick for me too.