Insufficient Permission for User Permission

Hi, I’m having trouble getting a user with all the permissions to assign a user to an employee.

He calls me “Insufficient Permission for User Permission.”

Touch all roles, add user permissions about the company, employee, etc.

I don’t realize how to fix it, only Administrator is able to do it.

If any of them had a similar case, the council would attack him.


If you have console access ‘bench reset-perms’ is one option (to return you to the ‘standard’ permission state).

1 Like

Thanks @clarkej! It worked perfect!

I didn’t know that command.

Good to hear that got you unstuck!

This is handy Bench Commands Cheatsheet

edit: comparing the cheatsheet with the console command list - the console offers far more - the cheatsheet is dated. ‘cloud’ users do not have console access (that I am aware) - so cannot use bench commands.

I guess for help they can contact

I have same problem.
I dont know how to use code
Any easy way for a normal user to set the insufficient permission setting

You might say it’s easy but learning does demand time and effort?

Tell us what you tried and give context: Commands, steps you followed, refer to posts, docs or a screenshot always help. Indicate the actual versus expected results. Include any error traceback along with the command you ran that got you that result.

Most often the way forward can be found by self search of the forum.

If you are stuck ask here and someone may offer you a pointer. Of course help here is voluntary.

1 Like