Intall frappe bench on Centos 6

Hi, installation of bench and framework on Centos 6 by ‘Easy Way’

Command wget …- first it gave unable to resolve host address ‘…, then it gave use’ --no-check-certificate’. Finally it saved file "’ in Home folder

Command sudo bash asks password for host computer’. Does not take erpnext or host computer password

Can you help me overcome this installing problem?

Hi Can anyone from Frappe team help me with installation

It will not ask for password if you run as root. Post any errors you get.

As you suggestion I gave su - and run went to root. Wget extracted in Home folder. On sudo bash…command message
Installing for centos 6 amd64
Adding Mariadb repo
Installing packages for Centos. This might take time…

Waited but no further further action

start with another clean install of CentOS and run the script with ‘–verbose’ option.

Two suggestions

  • Use CentOS 7
  • Make sure that your server has good internet connectivity

Thanks it worked with --verbose

During installation there was error: Cannot retrieve metalink for repository: epel. Please verify its path and try again

and exited

One possibility: Is is because I have DHCP link on BB router for my Linux machine? Do I need fixed IP setting for frappe install?

Do I need to update certificate to resolve epel error?

Seems like an environment issue. Check connectivity / system time

I got download error for file MariaDB-5.5.42-Centos-x86_64_Server.rpm [Errno 14] Pycurl Error-18 "transfer closed with remaining 388855 B

I rerun It completed file download and extract but gave error mysql-server- was supposed to be removed but is not!

Failed :

MariaDB-server.x86_64 0:5.5.42-1.e16 mysql-server.x86_64 0:5.1.52-1.e16_0.1

I have tried again with clean install of centos 6

It has failed at same point. If it was internet connectivity/speed issue that would not be the case

I sucessfully installed Frappe bench on my Centos 6 server. (I stopped and removed the mysql server before running sudo bash

I noted the default passwords. However login as Administrator was denied. I also tried login as frappe. Then logged in as root and created new apps successfully. Next when I gave bench new-site library it is also denying Mysql password from the default provided. Why am I getting login error with default passwords?

I gave bench start. It gives operation error 1025