Internal Server Error after restoring the backup on ERPNext running in Virtualbox


I have restored backup of following files successfully in my erpnext running on Virtualbox machine


I used this command.

bench --site [sitename] --force restore [path to database backup file] --with-private-files [relative-path-to-private-files-backup-file] --with-public-files [relative-path-to-public-files-backup-file]

after the restore, do I need to run any other command because I am getting “Internal server error” when I click on Login.


junaid Hussain
Riyadh, Saudi Arabia

Is the ERPNext that you are restoring to the same version as the one you backed up from?

Try bench migrate

when i try bench migrate command in frappe-bench folder

i get error

could not find app “erp_support”

Has bench update been tried?

Create new app with name erp_support and try restart bench it should work after that

Just to update here

I set up a fresh erpnext on Virtualbox and without upgrading I set up erpnext to check versions

here the versions

ERPNext:** v12.10.1 (version-12)
Frappe Framework:** v12.8.0 (version-12)

When I check erpnext cloud version status, I see

ERPNext: v12.12.1 (version-12)
ERPNext Support: v0.0.3 (master)
Frappe Framework: v12.10.2 (version-12)
Journeys: v0.0.1 (version-12)

so the version was different.

I run the command bench update and run the erpnext again to see the new version.

Installed Apps

ERPNext: v12.12.1 (version-12)
Frappe Framework: v12.10.2 (version-12)

now both versions of erpnext on Virtualbox and on the cloud are the same but erpnext on virtualbox does not show

ERPNext Support: v0.0.3 (master)
Journeys: v0.0.1 (version-12)

I restored the database again but still getting error

Site site1.local has been restored
frappe@ubuntu:~/frappe-bench$ bench migrate
Migrating site1.local
Could not find app “erpnext_support”

I removed them by the command in sites directory
bench --site site1.local remove-from-installed-apps erpnext_support
bench --site site1.local remove-from-installed-apps journeys

run again bench migrate and it worked.

run the erpnext on Virtualbox and it worked.

I hope erpnext support and journeys will be included in the ERPNext-Production.ova file so we do not need to remove these apps to work ERP

Thanks for the help

what is the command to create a new app of erp_support or journeys

Something like that

bench new-app erp_support

{App Title (defaut: Lib Mgt): erp support
App Description: Support
App Publisher: Frappe
App Email:
App Icon (default ‘octicon octicon-file-directory’): octicon octicon-book
App Color (default ‘grey’): #589494
App License (default ‘MIT’): GNU General Public License}

yes smino

i tried bench update and then run bench migrate but erp_support and journey app was missing. I deleted both app and tried bench migrate and it worked.

thanks for your help