Iphone App Error


When I try ad login with the iPhone app, I get a desk.html erpnext.domain failed with status 500.

I have tried installing new site, new user, reinstall iPhone app and no change.

Any ideas?


Instead of using the apps on smartphones, (both iPhone and Android are outdated), just use a regular internet browser. All phones have them and you can download whatever browser works best for you.

Our experience has been that iOS in general does not play well with ERPNext even on browsers. The browsers act very differently form those on windows, ChromeOS, and Android. I have many Android tablet deployed running the Chrome browser and racking up tons of ERPNext sales invoices every day.

You may have better luck that we did with your Apple devices, so it’s just best to try first and don’t expect the same result even on 2 iPads of the same generation. We made the mistake of testing on the previous iPad generation and found it worked with the Chrome browser. When we then tried to get it to work on 16 iPads all of the same generation at one of our client locations, we could only ever get 2 or 3 of them to work. So, we ate the cost of replacing them all with Android tablets from a cellular carrier and they all worked on the very first try. They continue racking up sales now even after 6 months.

So the best is to try it on the exact device you want to use. If it works, your are good. Just don’t expect it to be replicated on every Apple device. That will just bring you embarrassment.


I’m more of an app user and it did work when I first installed. I think it might be to do with enabling 2fa.

I will dig a bit more and if I find a solution il post otherwise as you suggest il just use the web.

In any case, I am now changing my design. The idea was to have woocommerce and link to erp but that seems silly consider there is a full cart capability on ERPNext. Having a single platform will be amazing and I can do everything I need without touching a single line of code.

Now just need to figure out all the minor issues I’m getting such as bench manager failing to update but bench update via SSH works perfectly.


1 Like

I have also faced error while connecting the iTunes with the iPhone and it was showing an unknown error has occurred due to the iTunes Error code 590624. But after fixing it all of these problems got solved.