Is there a "Easy Install" script for Debian 9

I have been using the Debian 8 stable images as the basis for my ERPnext work, but Debain 9 has been around for a long time now and I would like to be using it with ERPNext in my production setup.

At this point the file errors when trying to use it to install on Debian 9. The error says it does not support Debian 9, please use Debian 8.

Is anyone working on a new version of so we can use Debian 9 as our servers?

It would be a shame to have the latest ERPnext stuck on an old server OS.

I have also seen efforts to do it manually that are hitting unresolved errors so I am not going to try that route either.


@bkm We are working on it.

Basically, some package dependencies are breaking.

OK. Thank you for the update. I am sure others will be happy to hear this as well.


Hello - I have been trying to install erpnext on debian 9 and I keep getting pipe broken errors, and will get me to login screen but not setup wizard.

Where are we on Debian 9 and erpNEXT anyone.

thank you

You can do a manual install from here… (it is very simple if you follow it exactly)

I was never able to get it running with this - not sure but I am still learning so likely user error!

Sorry… my lengthy monologue did not need to be inflicted on this topic so I deleted it.

BKM :upside_down_face:

Hello - I have tried this easy script on Debian 9 3x now (erpnext_admin_guide | ERPNext Administrators Guide)

and ends in this:

    to retry, use: --limit @/tmp/.bench/playbooks/site.retry

PLAY RECAP *****************************************************************************************************************
localhost : ok=72 changed=12 unreachable=0 failed=1

Passwords saved at ~/passwords.txt
Traceback (most recent call last):
File “”, line 420, in
File “”, line 122, in install_bench
run_playbook(‘site.yml’, sudo=True, extra_vars=extra_vars)
File “”, line 338, in run_playbook
success = subprocess.check_call(args, cwd=os.path.join(cwd, ‘playbooks’))
File “/usr/lib/python2.7/”, line 186, in check_call
raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command ‘[‘ansible-playbook’, ‘-c’, ‘local’, ‘site.yml’, ‘-e’, ‘@/tmp/extra_vars.json’, ‘-vvvv’, ‘–become’, ‘–become-user=erpnext’]’ returned non-zero exit status 2

I have tried manual install 5x and nothing I do on fresh installs of Debian 9 will run erpnext. Why is it recommended if it wont run? I have spent over 30 hours and counting