Is there some "setting" that will allow me change the timeout of a report?

I have been running the same report for several hours and it always times out at about 2 minutes of processing. It never seems to trigger the “Prepared Report” function that is supposed to trigger when a report takes longer than 30 seconds.

So, I need to make the timeout window longer.

Where have you been doing this in v13?


You can set custom timeout

bench config http-timeout <integer>
bench setup supervisor
bench setup nginx

If you don’t want to increase your timeout limit for the whole system. I believe there is a checkbox in the report doctype called “Prepared Report” If this is checked It should force the report to be build in background job, then accessed when it’s done being built.